Bug 1258240 - kernel crash hard LOCKUP
kernel crash hard LOCKUP
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
: 1258237 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 09:29 EDT by Ronald L Humble
Modified: 2016-11-06 11:10 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-10 11:14:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
abrt dir and /var/log/messages (111.29 KB, application/x-gzip)
2015-08-30 09:31 EDT, Ronald L Humble
no flags Details

  None (edit)
Description Ronald L Humble 2015-08-30 09:29:05 EDT
Description of problem: kernel crash hard LOCKUP


Version-Release number of selected component (if applicable):
kernel-4.2.0-0.rc6.git0.2.fc23.x86_64
kernel-4.2.0-0.rc8.git0.1.fc23.x86_64

How reproducible:
machine will hard crash within 24 hours. I have tried leaving in multi-user (text) mode with no difference in crashing. Fresh KDE Workstation install.

Steps to Reproduce:
1. Boot
2.
3.

Actual results: Machine crash within 24 hours or less. Sometimes usable for hours, sometimes minutes.


Expected results: Machine does not crash.


Additional info:
coredump in attachment is from oops-2015-08-29-22:19:16-712-0 (reference Aug 29 22:19:17 entry in 150830.kernel.messages.txt. Crashes seem totally random, though perhaps more frequent if the desktop is in active use (KDE/XFCE/icewm).

I have no idea if crash due to a hardware defect or just my particular hardware.
Comment 1 Ronald L Humble 2015-08-30 09:31:51 EDT
Created attachment 1068441 [details]
abrt dir and /var/log/messages
Comment 2 Justin M. Forbes 2015-08-31 08:13:57 EDT
Can you reproduce this with the rc8 kernel that is now available?
Comment 3 Josh Boyer 2015-08-31 09:36:06 EDT
*** Bug 1258237 has been marked as a duplicate of this bug. ***
Comment 4 Ronald L Humble 2015-08-31 09:58:37 EDT
Yes both rc6 and rc8 caused crash. In the tarball I hope is 150830.kernel.messages.txt which lists rc8 as running when this crash occurred.

I compiled and built kernel-4.1.6-200.fc23.x86_64.rpm (one crash in building) and installed on 150831 12UTC. I will see how that kernel performs for me. Thanks for your prompt attention.
Comment 5 Josh Boyer 2015-08-31 10:05:58 EDT
Aug 29 22:19:15 rumble kernel: ------------[ cut here ]------------
Aug 29 22:19:15 rumble kernel: WARNING: CPU: 1 PID: 0 at kernel/watchdog.c:338 watchdog_overflow_callback+0x79/0xa0()
Aug 29 22:19:15 rumble kernel: Watchdog detected hard LOCKUP on cpu 1
Aug 29 22:19:15 rumble kernel: Modules linked in:
Aug 29 22:19:15 rumble kernel: bnep bluetooth rfkill ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_broute bridge stp llc ebtable_nat ebtable_filter ebtables ip6table_mangle ip6table_security ip6table_raw ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_filter ip6_tables iptable_mangle iptable_security iptable_raw iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack tda18271 lgdt330x cx88_dvb cx88_vp3054_i2c ir_lirc_codec videobuf2_dvb lirc_dev ir_mce_kbd_decoder ir_jvc_decoder ir_rc6_decoder ir_sony_decoder ir_sharp_decoder ir_xmp_decoder ir_rc5_decoder ir_sanyo_decoder ir_nec_decoder rc_hauppauge tuner_simple tuner_types tda9887 coretemp kvm_intel kvm btrfs tda8290 gpio_ich iTCO_wdt iTCO_vendor_support ppdev cx88_alsa cx8800 xor tuner raid6_pq cx8802 jfs cx88xx
Aug 29 22:19:15 rumble kernel: videobuf2_core videobuf2_dma_sg videobuf2_memops saa7164 s5h1411 tveeprom rc_core dvb_core v4l2_common i2c_i801 snd_hda_codec_hdmi videodev media snd_hda_codec_realtek snd_hda_codec_generic snd_hda_intel lpc_ich snd_hda_codec snd_hda_core snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd parport_pc soundcore parport shpchp acpi_cpufreq nfsd auth_rpcgss nfs_acl lockd grace sunrpc nouveau serio_raw firewire_ohci ata_generic firewire_core pata_acpi crc_itu_t video r8169 mxm_wmi wmi i2c_algo_bit drm_kms_helper mii ttm pata_jmicron drm
Aug 29 22:19:15 rumble kernel: CPU: 1 PID: 0 Comm: swapper/1 Not tainted 4.2.0-0.rc8.git0.1.fc23.x86_64 #1
Aug 29 22:19:15 rumble kernel: Hardware name: MICRO-STAR INTERNATIONAL CO.,LTD MS-7238/MS-7238, BIOS V1.8 12/01/2007
Aug 29 22:19:15 rumble kernel: 0000000000000000 0a380371ffc85f74 ffff88016fc85aa0 ffffffff8176ea7a
Aug 29 22:19:15 rumble kernel: 0000000000000000 ffff88016fc85af8 ffff88016fc85ae0 ffffffff8109e456
Aug 29 22:19:15 rumble kernel: 0000000000000000 ffff880169278000 0000000000000000 ffff88016fc85c00
Aug 29 22:19:15 rumble kernel: Call Trace:
Aug 29 22:19:15 rumble kernel: <NMI>  [<ffffffff8176ea7a>] dump_stack+0x45/0x57
Aug 29 22:19:15 rumble kernel: [<ffffffff8109e456>] warn_slowpath_common+0x86/0xc0
Aug 29 22:19:15 rumble kernel: [<ffffffff8109e4e5>] warn_slowpath_fmt+0x55/0x70
Aug 29 22:19:15 rumble kernel: [<ffffffff811509c9>] watchdog_overflow_callback+0x79/0xa0
Aug 29 22:19:15 rumble kernel: [<ffffffff81195740>] __perf_event_overflow+0x90/0x1c0
Aug 29 22:19:15 rumble kernel: [<ffffffff81196344>] perf_event_overflow+0x14/0x20
Aug 29 22:19:15 rumble kernel: [<ffffffff81033a67>] intel_pmu_handle_irq+0x1e7/0x470
Aug 29 22:19:15 rumble kernel: [<ffffffff8102a386>] perf_event_nmi_handler+0x26/0x40
Aug 29 22:19:15 rumble kernel: [<ffffffff81018893>] nmi_handle+0x83/0x120
Aug 29 22:19:15 rumble kernel: [<ffffffff81018e44>] default_do_nmi+0xb4/0xf0
Aug 29 22:19:15 rumble kernel: [<ffffffff81018f6a>] do_nmi+0xea/0x140
Aug 29 22:19:15 rumble kernel: [<ffffffff817773c4>] end_repeat_nmi+0x1a/0x1e
Aug 29 22:19:15 rumble kernel: [<ffffffff810e42a2>] ? queued_spin_lock_slowpath+0x162/0x180
Aug 29 22:19:15 rumble kernel: [<ffffffff810e42a2>] ? queued_spin_lock_slowpath+0x162/0x180
Aug 29 22:19:15 rumble kernel: [<ffffffff810e42a2>] ? queued_spin_lock_slowpath+0x162/0x180
Aug 29 22:19:15 rumble kernel: <<EOE>>  <IRQ>  [<ffffffff81774e9f>] _raw_spin_lock_irqsave+0x3f/0x50
Aug 29 22:19:15 rumble kernel: [<ffffffffa0158cbe>] nvkm_fantog_update+0x4e/0x120 [nouveau]
Aug 29 22:19:15 rumble kernel: [<ffffffffa0158de5>] nvkm_fantog_set+0x35/0x40 [nouveau]
Aug 29 22:19:15 rumble kernel: [<ffffffffa01582cc>] nvkm_fan_update+0xec/0x1e0 [nouveau]
Aug 29 22:19:15 rumble kernel: [<ffffffffa01583f9>] nvkm_therm_fan_set+0x19/0x20 [nouveau]
Aug 29 22:19:15 rumble kernel: [<ffffffffa0157bfc>] nvkm_therm_update+0x11c/0x2d0 [nouveau]
Aug 29 22:19:15 rumble kernel: [<ffffffffa0157dca>] nvkm_therm_alarm+0x1a/0x20 [nouveau]
Aug 29 22:19:15 rumble kernel: [<ffffffffa015b472>] nv04_timer_alarm_trigger+0x122/0x170 [nouveau]
Aug 29 22:19:15 rumble kernel: [<ffffffffa015b521>] nv04_timer_alarm+0x61/0xc0 [nouveau]
Aug 29 22:19:15 rumble kernel: [<ffffffffa0158d82>] nvkm_fantog_update+0x112/0x120 [nouveau]
Aug 29 22:19:15 rumble kernel: [<ffffffffa0158daa>] nvkm_fantog_alarm+0x1a/0x20 [nouveau]
Aug 29 22:19:15 rumble kernel: [<ffffffffa015b472>] nv04_timer_alarm_trigger+0x122/0x170 [nouveau]
Aug 29 22:19:15 rumble kernel: [<ffffffffa015b5e2>] nv04_timer_intr+0x62/0x80 [nouveau]
Aug 29 22:19:15 rumble kernel: [<ffffffffa015211b>] nvkm_mc_intr+0xfb/0x170 [nouveau]
Aug 29 22:19:15 rumble kernel: [<ffffffff810f3b24>] handle_irq_event_percpu+0x74/0x180
Aug 29 22:19:15 rumble kernel: [<ffffffff810f3c60>] handle_irq_event+0x30/0x60
Aug 29 22:19:15 rumble kernel: [<ffffffff810f6f7f>] handle_edge_irq+0x6f/0x130
Aug 29 22:19:15 rumble kernel: [<ffffffff81016e42>] handle_irq+0x72/0x120
Aug 29 22:19:15 rumble kernel: [<ffffffff810bd61a>] ? atomic_notifier_call_chain+0x1a/0x20
Aug 29 22:19:15 rumble kernel: [<ffffffff81777cdf>] do_IRQ+0x4f/0xe0
Aug 29 22:19:15 rumble kernel: [<ffffffff81775beb>] common_interrupt+0x6b/0x6b
Aug 29 22:19:15 rumble kernel: <EOI>  [<ffffffff8101f07c>] ? mwait_idle+0x8c/0x140
Aug 29 22:19:15 rumble kernel: [<ffffffff8101f61f>] arch_cpu_idle+0xf/0x20
Aug 29 22:19:15 rumble kernel: [<ffffffff810df3ba>] default_idle_call+0x2a/0x40
Aug 29 22:19:15 rumble kernel: [<ffffffff810df6f9>] cpu_startup_entry+0x2c9/0x320
Aug 29 22:19:15 rumble kernel: [<ffffffff8104cc86>] start_secondary+0x186/0x1c0
Aug 29 22:19:15 rumble kernel: ---[ end trace fe9aefd42436b8f7 ]---
Comment 6 Ronald L Humble 2015-09-01 12:01:49 EDT
Running 28 hours on local compile/install of kernel-4.1.6-200.fc23.x86_64.rpm.
No issues.
Comment 7 Ronald L Humble 2015-11-10 11:08:36 EST
Have been running kernel 4.2.3-300.fc23.x86_64 from updates-testing since October eighth with no crash issues.
Comment 8 Fedora Kernel Team 2015-11-10 11:14:30 EST
Thank you.

Note You need to log in before you can comment on or make changes to this bug.