Bug 1258252 - Version mismatch for LLVM package
Version mismatch for LLVM package
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: llvm (Show other bugs)
epel7
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dave Johansen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 10:50 EDT by Dávid Halász
Modified: 2015-09-02 18:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-02 10:45:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dávid Halász 2015-08-30 10:50:00 EDT
Description of problem:
When installing LLVM, the package manager says v3.4.2, but the llvm-config command shows v3.6.1.

Version-Release number of selected component (if applicable):
LLVM-3.4.2-7.el7.x86_64 on Centos 7.1

Steps to Reproduce:
1. Enable the EPEL7 repository
2. yum -y install llvm
3. yum info llvm | grep Version
4. llvm-config --version

Actual results:
$ yum info llvm | grep Version
Version     : 3.4.2
$ llvm-config --version
3.6.1

Expected results:
$ yum info llvm | grep Version
Version     : 3.4.2
$ llvm-config --version
3.4.2
Comment 1 Dave Johansen 2015-09-01 11:13:24 EDT
Do you have another version of LLVM built/installed on your machine? It appears that llvm-config isn't included as part of the current version available in EPEL 7.

$ yum provides "*/llvm-config"
No Matches found
Comment 2 Dávid Halász 2015-09-02 02:33:21 EDT
I think llvm-devel provides llvm-config, but now it looks like the version is good again.
Comment 3 Dave Johansen 2015-09-02 10:45:21 EDT
Closing as not a bug.
Comment 4 Dave Johansen 2015-09-02 18:57:41 EDT
For the sake of documentation, it is llvm-devel that provides it. It's just that on 64-bit systems, it's called llvm-config-64.
$ yum provides "*/llvm-config-64"
llvm-devel-3.4.2-4.el6.x86_64 : Libraries and header files for LLVM
Repo        : epel
Matched from:
Filename    : /usr/bin/llvm-config-64

Note You need to log in before you can comment on or make changes to this bug.