Bug 1258257 - dnf does not work on Raspberry Pi 2 - ends with traceback
dnf does not work on Raspberry Pi 2 - ends with traceback
Status: CLOSED DUPLICATE of bug 1250700
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
armhfp Unspecified
unspecified Severity high
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 11:15 EDT by Tomáš Hozza
Modified: 2015-09-01 08:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-01 08:39:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomáš Hozza 2015-08-30 11:15:04 EDT
Description of problem:
After trying to install binutils and tar on Raspberry Pi 2 on image based on F22 armhfp minimal image [1] without any system tweaks (except booting) DNF does not work. The F22-3 image contained dnf version 1.0.0. That version froze after invocation. I updated it using YUM to version 1.1.0 and this version ends with traceback.

Version-Release number of selected component (if applicable):
dnf-1.1.0-2.fc22.noarch

How reproducible:
always

Steps to Reproduce:
1. just running 'dnf install binutils tar'

Actual results:
[root@localhost pi]# dnf -v install binutils tar
cachedir: /var/cache/dnf
Loaded plugins: copr, playground, kickstart, debuginfo-install, migrate, generate_completion_cache, builddep, reposync, protected_packages, needs-restarting, Query, config-manager, noroot, download
DNF version: 1.1.0
Fedora 22 - armhfp                              4.0 MB/s |  37 MB     00:09    
not found deltainfo for: Fedora 22 - armhfp
not found updateinfo for: Fedora 22 - armhfp
Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 193, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 139, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1082, in run
    self._process_demands()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 804, in _process_demands
    load_available_repos=lar)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 244, in fill_sack
    self._add_repo_to_sack(r.id)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 126, in _add_repo_to_sack
    load_updateinfo=True)
AssertionError: Can not load repo.

Expected results:
binutils and tar being installed just fine.

Additional info:
Note that YUM works just fine. DNF claimed there are no delta RPMs for armhf, but YUM was able to find those and use them.

Currently DNF does not work at all in the situation I described.

I created the image for RPi2 from F22 minimal arm image [1] and followed [2] to tweak the booting.

[1] http://dl.fedoraproject.org/pub/fedora/linux/releases/22/Images/armhfp/Fedora-Minimal-armhfp-22-3-sda.raw.xz
[2] http://jonarcher.info/2015/02/getting-fedora-21-raspberry-pi-2/
Comment 1 Honza Silhan 2015-09-01 08:39:06 EDT
attach the metadata to dup bug, if you can, please

*** This bug has been marked as a duplicate of bug 1250700 ***

Note You need to log in before you can comment on or make changes to this bug.