This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1258269 - AucTeX attempts to run nonexistent pdfamstex command
AucTeX attempts to run nonexistent pdfamstex command
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: emacs-auctex (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jonathan Underwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 14:59 EDT by Matthew Saltzman
Modified: 2015-09-02 11:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-02 08:41:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
basicart.sty package--the one that triggers AucTeX to use pdfamstex. (14.16 KB, text/plain)
2015-08-30 14:59 EDT, Matthew Saltzman
no flags Details
Example LaTeX file that uses package basicart.sty and illustrates the failure when edited with emacs and AucTeX. (379 bytes, text/x-tex)
2015-08-30 15:01 EDT, Matthew Saltzman
no flags Details
basicart.sty with most stuff removed. (1.24 KB, text/plain)
2015-09-01 18:27 EDT, Matthew Saltzman
no flags Details
Simlified LaTeX file using basicart1.sty that illustrates the issue. (331 bytes, text/x-tex)
2015-09-01 18:31 EDT, Matthew Saltzman
no flags Details

  None (edit)
Description Matthew Saltzman 2015-08-30 14:59:57 EDT
Created attachment 1068490 [details]
basicart.sty package--the one that triggers AucTeX to use pdfamstex.

Description of problem:
emacs-auctex tries to determine which of several tex/latex binaries should be used to process the file being edited. For some files, it will attempt to invoke pdfamstex, but there doesn't seem to be any TeXLive package in Fedora that provides that binary.


Version-Release number of selected component (if applicable):
texlive-2014-8.20140525_r34255.fc22.x86_64

How reproducible:
Always for certain LaTeX source files.

Steps to Reproduce:
1. Install emacs and emacs-auctex RPMs
2. Create a LaTeX document using the article \documentstyle and including the attached article.sty package with \usepackage{basicart}
3. Edit the file with emacs and attempt to compile with C-c C-c

Actual results:
One of the pop-down menus in Emacs is for AmS-TeX. The C-c C-c command shows in the status window "Command: (default AmSTeX)". The default command fails with the following error in the output buffer:

Running `AmSTeX' on `hack' with ``pdfamstex   -interaction=nonstopmode "\input" hack.tex''
/bin/sh: pdfamstex: command not found



Expected results:
The compile works.

Additional info:
I'm not sure if this is an AucTeX bug or a TeXLive bug. I don't know how AucTeX decides which binary to invoke or what about the attached style file triggers the use of pdfamstex instead of pdflatex, but it seems as though if pdfamstex exists, it should be available in TeXLive. Fedora's TeXLive does include amstex, but not pdfamstex. But plain latex or amstex won't work with certain kinds of included graphics--one needs to go directly to PDF in those cases. The latest AucTeX seems to default to the direct-to-pdf commands, such as pdflatex.
Comment 1 Matthew Saltzman 2015-08-30 15:01:25 EDT
Created attachment 1068491 [details]
Example LaTeX file that uses package basicart.sty and illustrates the failure when edited with emacs and AucTeX.
Comment 2 Tom "spot" Callaway 2015-08-31 14:13:31 EDT
I think you want to use pdftex (not pdfamstex). I'm not sure where the pdfamstex reference is coming from. It seems like this probably should be fixed by emacs-auctex updating to the latest code in git.
Comment 3 Matthew Saltzman 2015-08-31 14:30:51 EDT
Can you switch this bug to emacs-auctex, or should I refile?
Comment 4 Matthew Saltzman 2015-09-01 17:24:13 EDT
Never mind, I see I can make the change.
Comment 5 Jonathan Underwood 2015-09-01 17:41:06 EDT
Can't reproduce that. That basicart.sty seems broken. When I try to compile this:

\documentclass{article}
\usepackage{basicart}

\begin{document}
hello
\end{document}

I get:

ERROR: Undefined control sequence.

--- TeX said ---
<argument> \footnotesize \@LeftHead 
                                    
l.6 \end{document}
                  
--- HELP ---
TeX encountered an unknown command name. You probably misspelled the
name. If this message occurs when a LaTeX command is being processed,
the command is probably in the wrong place---for example, the error
can be produced by an \item command that's not inside a list-making
environment. The error can also be caused by a missing \documentclass
command.



Upload a minimal example demonstrating the problem so I can reproduce please.
Comment 6 Jonathan Underwood 2015-09-01 17:43:19 EDT
Sidenote: when you reassign the component in bugzilla, you also need to re-assign the person who the bug is assigned to. I am sure BZ used to do that automatically, but perhaps I misremember.
Comment 7 Matthew Saltzman 2015-09-01 18:27:17 EDT
Created attachment 1069234 [details]
basicart.sty with most stuff removed.

Deleted most of the complexity of basicart.sty.
Comment 8 Matthew Saltzman 2015-09-01 18:31:46 EDT
Created attachment 1069237 [details]
Simlified LaTeX file using basicart1.sty that illustrates the issue.

Commented out the line with the email address that appears to cause your issue. Also deleted all package references other than basicart1.sty. This should build with pdflatex. When you open with emacs and auctex, the indicated incorrect behavior is exhibited.
Comment 9 Matthew Saltzman 2015-09-01 18:34:05 EDT
(In reply to Jonathan Underwood from comment #6)
> Sidenote: when you reassign the component in bugzilla, you also need to
> re-assign the person who the bug is assigned to. I am sure BZ used to do
> that automatically, but perhaps I misremember.

Sorry, this is the first time I've tried to reassign a bug. Not sure how I would know how to find the right person.
Comment 10 Jonathan Underwood 2015-09-02 08:41:10 EDT
OK, have confirmed this issue still arises in AucTeX 11.88.6 from ELPA, so it's really an upstream issue. I've sent a bug report upstream, although the arcane and ridiculous bug tracker they use means it won't appear in the auctex-bug@gnu.org archive until it's next refreshed.

Closing as an upstream issue.
Comment 11 Jonathan Underwood 2015-09-02 11:31:29 EDT
http://debbugs.gnu.org/cgi/bugreport.cgi?bug=21401

Note You need to log in before you can comment on or make changes to this bug.