Bug 1258300 - Pidgin XMPP connection: SSL Handshake failed
Pidgin XMPP connection: SSL Handshake failed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Synacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 22:52 EDT by Brian Ward
Modified: 2016-01-11 04:01 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 04:01:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug ssl handshake error (18.72 KB, text/plain)
2015-12-21 12:01 EST, Matt Bagnara
no flags Details

  None (edit)
Description Brian Ward 2015-08-30 22:52:47 EDT
Description of problem:
Similar to Bug 1232349. 
https://bugzilla.redhat.com/show_bug.cgi?id=1232349
Pidgin fails to connect over SSL on an XMPP based server. Got the error: "SSL Handshake failed".

Version-Release number of selected component (if applicable):
pidgin-2.10.11-12.fc22

How reproducible:
Update to latest FC22 packages as of 8/30/2015:
nss-3.20.0-1.0.fc22 (maybe affected?)
openssl-1.0.1k-12.fc22 (maybe affected?)
pidgin-2.10.11-12.fc22

Steps to Reproduce:
1. Fresh install of FC22 from Live USB (downloaded 8/30/2015)
2. Updated all packages (8/30/2015).
3. Installed pidgin (8/30/2015).
4. Setup pidgin to connect to XMPP secured server.

Actual results:
"SSL Handshake failed".

Expected results:
Connection and buddy list shown.

Additional Info:
I performed a rollback to the FC22 installation before updating all packages, then installed pidgin, and everything worked fine.
nss-3.18.0-1.fc22
openssl-1.0.1k-8.fc22
pidgin-2.10.11-12.fc22

At least 3 others I work with have reported this problem on FC21, with latest updates applied, as well.
Comment 1 Rick Tavares 2015-12-01 11:14:17 EST
I am having the same issue
Comment 2 Matěj Cepl 2015-12-17 01:08:44 EST
Could you please provide us with a debug log? Disable all other accounts except for the one with SSL-enabled XMPP, and quit pidgin. Then switch to gnome-terminal and run

$ pidgin -d > ~/debug.log 2>&1

After reproducing the issue, please, attach debug.log to this bug.

Thank you
Comment 3 Matt Bagnara 2015-12-21 12:01 EST
Created attachment 1108338 [details]
Debug ssl handshake error

XMPP connection attempt using pidgin:

Linux mbagnara.fedora 4.2.3-300.fc23.x86_64
pidgin-2.10.11-14.fc23.x86_64
Comment 6 Brian Ward 2016-01-04 13:48:17 EST
I can no longer reproduce the problem.

Not sure what changes fixed the problem, but I'm running this now and it works:
nss.x86_64                         3.21.0-1.1.fc22                      @updates
openssl.x86_64                     1:1.0.1k-13.fc22                     @updates
pidgin.x86_64                      2.10.11-12.fc22                      @updates

Also Chris Pitmann (cpitman@redhat.com), managing the XMPP server, said in an email the problem was fixed as of Dec 22.  

Don't know if issue was in one of the libraries or the XMPP server itself.
Comment 7 Jan Synacek 2016-01-11 04:01:33 EST
Closing, per comment 6. This was very likely not a bug in pidgin, therefore I'm closing this as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.