Bug 1258389 - Updating the list of pinned hosts for a VM via REST does not work
Updating the list of pinned hosts for a VM via REST does not work
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RestAPI (Show other bugs)
---
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Roman Mohr
Shira Maximov
sla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-31 05:23 EDT by Roman Mohr
Modified: 2016-02-10 14:19 EST (History)
7 users (show)

See Also:
Fixed In Version: 3.6.0-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 09:40:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
ylavi: planning_ack+
rule-engine: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45441 master MERGED restapi: Fix PUT on host pinning update Never
oVirt gerrit 45525 ovirt-engine-3.6 MERGED restapi: Fix PUT on host pinning update Never

  None (edit)
Description Roman Mohr 2015-08-31 05:23:06 EDT
Description of problem:

When updating the list of pinned hosts of a VM, removing hosts is not possible. You can only add hosts.  

Version-Release number of selected component (if applicable):


How reproducible:
Create a vim with a list of pinned hosts. Then fetch it though REST, remove one host from the host list and PUT it, to update the VM.


Steps to Reproduce:
1. Create VM with multiple pinned hosts
2. Fetch the JSON/XML via REST
3. Remove the host 

Actual results:
In the database and the UI, you still see that all hosts are selected as before the config update via REST.


Expected results:
The response from the REST endpoint should still show all hosts like before the PUT, because this is a value which only gets effective afer a VM restart. But you should see in the UI, that the host is no longer selected, and the VM needs a restart.


Additional info:
Comment 1 Shira Maximov 2016-01-07 05:42:01 EST
verified on :  Red Hat Enterprise Virtualization Manager Version: 3.6.2-0.1.el6 

verifcation steps : 
1. create VM with pinning to multiple hosts
2.via REST:
PUT Request to : https://<engine ip>/ovirt-engine/api/vms/<vm_id>

body:
<vm>
<placement_policy>
<hosts>
<host id="<host_id_you want_keep>"/>
</hosts>
</placement_policy>
</vm>
Comment 2 Sandro Bonazzola 2016-01-13 09:40:37 EST
oVirt 3.6.0 has been released, closing current release

Note You need to log in before you can comment on or make changes to this bug.