Bug 1258401 - Should provide a friendly prompt that not allow to select "ISO/OVA/PXE" when setup additional host
Should provide a friendly prompt that not allow to select "ISO/OVA/PXE" when ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-hosted-engine (Show other bugs)
3.5.4
Unspecified Unspecified
low Severity medium
: ovirt-4.0.0-alpha
: ---
Assigned To: Fabian Deutsch
wanghui
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-31 05:54 EDT by wanghui
Modified: 2016-02-10 14:18 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 08:14:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wanghui 2015-08-31 05:54:36 EDT
Description of problem:
It should give a friendly prompt that not allow to select the "ISO/OVA/PXE" when setup additional host in HE page. Due to the engine deploy type will be ignore in additional host setup process, we should give a friendly prompt to let customer know.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.1-20150827.1.el7ev
ovirt-node-3.2.3-20.el7.noarch
ovirt-node-plugin-hosted-engine-0.2.0-18.0.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor7-7.1-20150827.1.el7ev
2. Enabled network with dhcp type
3. Change to Hosted Engine page
4. Select "PXE Boot Engine VM" and click <Start additional host setup>

Actual results:
1. After step4, it change to additional host setup process without any prompt info. But the VM deploy type which be selected in the TUI page is ignored during the additional host setup process.

Expected results:
1. After step4, it should give a friendly prompt info that not allow to select the "ISO/OVA/PXE" when setup additional host in HE page.

Additional info:
Comment 1 Fabian Deutsch 2015-09-30 09:46:39 EDT
I do not see an easy or elegant way to implement this.
Comment 2 Fabian Deutsch 2015-12-02 08:14:53 EST
In 4.0 we won't have the TUI anymore, thus closing.

Note You need to log in before you can comment on or make changes to this bug.