Bug 125878 - pilot-xfer segfaults when backing up Tungsten T
pilot-xfer segfaults when backing up Tungsten T
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pilot-link (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-13 00:32 EDT by John Sheahan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-30 09:34:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sheahan 2004-06-13 00:32:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040608 Firefox/0.8.0+

Description of problem:
when I run
pilot-xfer -p /dev/ttyUSB0 -b .palm/backup

it runs fine for a while backing up merrily, then segfaults on 
"Net Library.prc". I googled, found
http://lists.jpilot.org/pipermail/jpilot/2003-May/002136.html

the suggested fix in the page linked
LP_BUF_SIZE in dlp.c, so I set it to 0x1ffff 
works for me.



Version-Release number of selected component (if applicable):
pilot-link-0.11.8-3.1

How reproducible:
Always

Steps to Reproduce:
1. plug a current tungsten T into USB cradle 
2. pilot-xfer -p /dev/ttyUSB0 -b .palm/backup
3. press hotsync button
    

Actual Results:  segfaults on one particular file being transferred

Expected Results:  backup succeeds

Additional info:

palm has current sound patch from Palm.
Comment 1 Ngo Than 2004-06-30 09:34:01 EDT
it's fixed in 0.11.8-6. Thanks for your report

Note You need to log in before you can comment on or make changes to this bug.