Bug 1258803 - [engine] Enroll certificate failure - NPE org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase] (VdsDeploy)
[engine] Enroll certificate failure - NPE org.ovirt.engine.core.bll.hostdeplo...
Status: CLOSED DUPLICATE of bug 1254965
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.6.0
Assigned To: Moti Asayag
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 06:24 EDT by Jiri Belka
Modified: 2016-02-10 14:36 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-02 05:48:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (95.39 KB, application/x-gzip)
2015-09-01 06:24 EDT, Jiri Belka
no flags Details

  None (edit)
Description Jiri Belka 2015-09-01 06:24:37 EDT
Created attachment 1068934 [details]
engine.log

Description of problem:

a host is in maintenance and after Enroll Certificate action in Admin Portal the host ends in Install Failed state.

2015-09-01 12:11:19,342 DEBUG [org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase] (VdsDeploy) [c48173f] Installation of 10-34-62-205.rhev.lab.eng.brq.redhat.com: Event QueryString TERMINATION_COMMAND null
2015-09-01 12:11:19,342 DEBUG [org.ovirt.otopi.dialog.MachineDialogParser] (VdsDeploy) [c48173f] env-get ODEPLOY/installIncomplete
2015-09-01 12:11:19,342 DEBUG [org.ovirt.otopi.dialog.MachineDialogParser] (VdsDeploy) [c48173f] Got: ###
2015-09-01 12:11:19,342 DEBUG [org.ovirt.otopi.dialog.MachineDialogParser] (VdsDeploy) [c48173f] Got: ### Processing ended, use 'quit' to quit
2015-09-01 12:11:19,342 DEBUG [org.ovirt.otopi.dialog.MachineDialogParser] (VdsDeploy) [c48173f] Got: ### COMMAND>
2015-09-01 12:11:19,343 DEBUG [org.ovirt.otopi.dialog.MachineDialogParser] (VdsDeploy) [c48173f] Got: ***D:VALUE ODEPLOY/installIncomplete=none:None
2015-09-01 12:11:19,344 DEBUG [org.ovirt.otopi.dialog.MachineDialogParser] (VdsDeploy) [c48173f] nextEvent: DisplayValue ODEPLOY/installIncomplete=none:null
2015-09-01 12:11:19,344 DEBUG [org.ovirt.otopi.dialog.MachineDialogParser] (VdsDeploy) [c48173f] env-get ODEPLOY/installIncomplete=null:null
2015-09-01 12:11:19,344 ERROR [org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase] (VdsDeploy) [c48173f] Error during deploy dialog: java.lang.NullPointerException
        at org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase$6.call(VdsDeployBase.java:110) [bll.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase$6.call(VdsDeployBase.java:109) [bll.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase._nextTerminationEntry(VdsDeployBase.java:286) [bll.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase.processEvent(VdsDeployBase.java:643) [bll.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.VdsDeploy.processEvent(VdsDeploy.java:35) [bll.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase._threadMain(VdsDeployBase.java:319) [bll.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase.access$800(VdsDeployBase.java:45) [bll.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase$12.run(VdsDeployBase.java:386) [bll.jar:]
        at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_51]

2015-09-01 12:11:19,357 DEBUG [org.ovirt.engine.core.uutils.ssh.SSHClient] (pool-6-thread-1) [c48173f] Executed: 'umask 0077; MYTMP="$(TMPDIR="${OVIRT_TMPDIR}" mktemp -d -t ovirt-XXXXXXXXXX)"; trap "chmod -R u+rwX \"${MYTMP}\" > /dev/null 2>&1; rm -fr \"${MYTMP}\" > /dev/null 2>&1" 0; tar --warning=no-timestamp -C "${MYTMP}" -x &&  "${MYTMP}"/ovirt-host-mgmt DIALOG/dialect=str:machine DIALOG/customization=bool:True'
2015-09-01 12:11:19,379 DEBUG [org.ovirt.engine.core.uutils.ssh.SSHDialog] (pool-6-thread-1) [c48173f] execute leave
2015-09-01 12:11:19,380 ERROR [org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase] (pool-6-thread-1) [c48173f] Error during host 10-34-62-205.rhev.lab.eng.brq.redhat.com install: java.lang.NullPointerException
        at org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase$6.call(VdsDeployBase.java:110) [bll.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase$6.call(VdsDeployBase.java:109) [bll.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase._nextTerminationEntry(VdsDeployBase.java:286) [bll.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase.processEvent(VdsDeployBase.java:643) [bll.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.VdsDeploy.processEvent(VdsDeploy.java:35) [bll.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase._threadMain(VdsDeployBase.java:319) [bll.jar:]
...

in fact activating host works OK, the certs were not changed on the host. nothing in vdsm.log

seems like backend issue.

Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.12.master.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. have active host in 3.6 d/s env
2. put the host into maintenance
3. click Enroll certificate in Admin Portal

Actual results:
fails and host ends in install failed

Expected results:
should renew certificates and keep the host in maintenance

Additional info:
Comment 1 Moti Asayag 2015-09-02 05:48:13 EDT

*** This bug has been marked as a duplicate of bug 1254965 ***

Note You need to log in before you can comment on or make changes to this bug.