Bug 1258808 - bash: [: |/usr/bin/lesspipe.sh: binary operator expected
bash: [: |/usr/bin/lesspipe.sh: binary operator expected
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: less (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Viktor Jancik
Fedora Extras Quality Assurance
:
: 1259195 1259494 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 06:30 EDT by Yanko Kaneti
Modified: 2016-01-31 21:25 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-02 08:39:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yanko Kaneti 2015-09-01 06:30:01 EDT
less-479-2.fc24.x86_64, someone built that in rawhide yesterday after the commit was there for a week before that....

Perhaps what was meant in less.sh was
-if [ -x /usr/bin/lesspipe.sh ] && [ -z $LESSOPEN ]; then
+if [ -x /usr/bin/lesspipe.sh ] && [ -z "$LESSOPEN" ]; then
Comment 1 Yanko Kaneti 2015-09-02 07:21:04 EDT
*** Bug 1259195 has been marked as a duplicate of this bug. ***
Comment 2 Viktor Jancik 2015-09-02 08:39:30 EDT
Fixed in rawhide:
https://koji.fedoraproject.org/koji/taskinfo?taskID=10928002

Thank you for pointing it out, I missed it.
Comment 3 Yanko Kaneti 2015-09-02 15:01:18 EDT
*** Bug 1259494 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.