Bug 1258859 - libsepol-devel can't be installed
libsepol-devel can't be installed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libsepol (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Lautrbach
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 08:20 EDT by Andreas Schneider
Modified: 2015-09-01 08:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-01 08:39:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Schneider 2015-09-01 08:20:57 EDT
Description of problem:

libsepol-devel can't be installed ...


krikkit:~ # dnf install krb5-devel
Last metadata expiration check performed 2:15:41 ago on Tue Sep  1 12:02:28 2015.
Error: package krb5-devel-1.13.2-6.fc23.i686 requires libselinux-devel, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)
krikkit:~ # dnf install libselinux-devel                                                                                                                                                
Last metadata expiration check performed 2:15:45 ago on Tue Sep  1 12:02:28 2015.
Error: package libselinux-devel-2.4-1.fc23.1.i686 requires pkgconfig(libsepol), but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)
krikkit:~ # dnf install libsepol
Last metadata expiration check performed 2:15:54 ago on Tue Sep  1 12:02:28 2015.
Package libsepol-2.4-3.fc23.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!
krikkit:~ # dnf install libsepol-devel
Last metadata expiration check performed 2:16:10 ago on Tue Sep  1 12:02:28 2015.
Error: package libsepol-devel-2.4-1.fc23.i686 requires libsepol.so.1, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)
krikkit:~ # dnf install libsepol-devel.x86_64
Last metadata expiration check performed 2:16:36 ago on Tue Sep  1 12:02:28 2015.
Error: package libsepol-devel-2.4-1.fc23.x86_64 requires libsepol = 2.4-1.fc23, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)
Comment 1 Andreas Schneider 2015-09-01 08:24:12 EDT
krikkit:~ # rpm -q libsepol
libsepol-2.4-3.fc23.x86_64
Comment 2 Petr Lautrbach 2015-09-01 08:33:40 EDT
It works with manually downloaded package:

# wget https://kojipkgs.fedoraproject.org//packages/libsepol/2.4/3.fc23/x86_64/libsepol-devel-2.4-3.fc23.x86_64.rpm

# rpm -qp --requires libsepol-devel-2.4-3.fc23.x86_64.rpm 
/usr/bin/pkg-config
libsepol = 2.4-3.fc23
libsepol.so.1()(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

# dnf install libsepol-devel-2.4-3.fc23.x86_64.rpm
...
Installed:
  libsepol-devel.x86_64 2.4-3.fc23


It seems to be problem on mirrors where there's no libsepol-devel-2.4-3.fc23.x86_64 available.
Comment 3 Petr Lautrbach 2015-09-01 08:39:31 EDT
So libsepol-2.4-3.fc23 was obsoleted as the update got bad karma -  https://bodhi.fedoraproject.org/updates/libsepol-2.4-3.fc23. You should use --allowerasing option to get back to -1 version:

# dnf install --enablerepo=updates-testing --allowerasing libsepol-devel

Note You need to log in before you can comment on or make changes to this bug.