Bug 1258864 - fencing_policies is not available in REST API output
fencing_policies is not available in REST API output
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.5.3
Unspecified Unspecified
unspecified Severity unspecified
: ovirt-3.5.5
: 3.5.5
Assigned To: Juan Hernández
Petr Matyáš
infra
: ZStream
Depends On:
Blocks: 1259211 1259214 1259253
  Show dependency treegraph
 
Reported: 2015-09-01 08:25 EDT by Pavel Zhukov
Modified: 2016-02-10 14:14 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-engine-3.5.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1259211 1259214 1259253 (view as bug list)
Environment:
Last Closed: 2015-10-26 14:33:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mgoldboi: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45599 ovirt-engine-3.5 MERGED restapi: Make mapper test more generic Never
oVirt gerrit 45600 ovirt-engine-3.5 MERGED core: adding API for Cluster Fencing Policy Never

  None (edit)
Description Pavel Zhukov 2015-09-01 08:25:24 EDT
Description of problem:
There is not fencing policies section under cluster in REST API

Version-Release number of selected component (if applicable):
rhevm-3.5.3.1-1.4.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Enable and change fencing_policy of cluster
2.  curl -v -k -H 'Content-Type: application/xml' -u 'admin@internal:XXXXXX' -X GET  https://rhevm.example.com//api/clusters/c81b57c6-350b-4a49-875b-a03732fc0874

Actual results:
No fencing_policies listed

Expected results:
Should be listed according to http://lists.ovirt.org/pipermail/engine-commits/2014-October/018489.html

Additional info:
Comment 1 Juan Hernández 2015-09-01 09:09:52 EDT
Pavel, this feature will be included in 3.6 (see bug 1127592). There are no plans to include it in 3.5 at the moment. Do we need it in 3.5?

Eli, is is feasible to backport this to 3.5?
Comment 2 Eli Mesika 2015-09-01 09:18:22 EDT
(In reply to Juan Hernández from comment #1)
> Pavel, this feature will be included in 3.6 (see bug 1127592). There are no
> plans to include it in 3.5 at the moment. Do we need it in 3.5?
> 
> Eli, is is feasible to backport this to 3.5?

Yes it is, needs Oved ack on that
Comment 3 Juan Hernández 2015-09-01 09:21:20 EDT
Oved, your input please.
Comment 6 Juan Hernández 2015-09-01 09:48:04 EDT
Backporting this change doesn't seem complicated. It requires two patches, one to do a small change in the test infrastructure and another for the real feature:

  restapi: Make mapper test more generic
  https://gerrit.ovirt.org/45599

  core: adding API for Cluster Fencing Policy
  https://gerrit.ovirt.org/45600
Comment 7 Oved Ourfali 2015-09-02 02:09:36 EDT
Okay. Targeting to 3.5.5.
Pavel and Moran - please ack.
Comment 8 Juan Hernández 2015-09-02 04:20:56 EDT
Please remember to ack and set the 3.5.z flag on the bugs required to regenerate the SDK as well, bug 1259211 and bug 1259214.
Comment 9 Philipp Gassmann 2015-09-02 05:42:43 EDT
Thanks for the fast backporting!
The documentation should be updated too, accordingly for 3.5.5 and 3.6
Comment 10 Eyal Edri 2015-10-12 13:36:50 EDT
setting missing ovirt-3.5.5 milestone for 3.5.5 bugs.
Comment 12 errata-xmlrpc 2015-10-26 14:33:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1938.html

Note You need to log in before you can comment on or make changes to this bug.