Bug 1258901 - [UX] Toggling wad property while vm is up shouldn't be greyed out
[UX] Toggling wad property while vm is up shouldn't be greyed out
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Tal Nisan
Kevin Alon Goldblatt
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 09:45 EDT by Ori Gofen
Modified: 2016-03-10 06:59 EST (History)
11 users (show)

See Also:
Fixed In Version: 3.6.0-16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 05:34:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (1.52 MB, text/plain)
2015-09-01 09:45 EDT, Ori Gofen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46817 master MERGED webadmin: Allow edit of wipe after delete when the VM is not down Never
oVirt gerrit 47009 ovirt-engine-3.6 MERGED webadmin: Allow edit of wipe after delete when the VM is not down Never
oVirt gerrit 47123 ovirt-engine-3.6.0 MERGED webadmin: Allow edit of wipe after delete when the VM is not down Never

  None (edit)
Description Ori Gofen 2015-09-01 09:45:18 EDT
Created attachment 1069009 [details]
log

Description of problem:
Changing "wipe after delete" property while VM is up is supported since oVirt 3.4, also it is working well when executing edit vm disk via python-sdk.


Version-Release number of selected component (if applicable):
rhevm-3.6-12.rpm

How reproducible:
100%

Steps to Reproduce:
1.have a vm + disk
2.start the vm
3.edit wad property while vm is up

Actual results:
the check box is greyed out

Expected results:
the check box shouldn't be greyed out

Additional info:
Comment 1 Allon Mureinik 2015-09-01 10:11:09 EDT
(In reply to Ori Gofen from comment #0)
> Created attachment 1069009 [details]
> log
> 
> Description of problem:
> Changing "wipe after delete" property while VM is up is supported since
> oVirt 3.4,
3.4.1, actually (see bug 1103679), but I agree, this is a regression.

Tal - let's have someone take a quick look please?
Comment 3 Ori Gofen 2015-09-01 10:30:30 EDT
(In reply to Allon Mureinik from comment #1)
> (In reply to Ori Gofen from comment #0)
> > Created attachment 1069009 [details]
> > log
> > 
> > Description of problem:
> > Changing "wipe after delete" property while VM is up is supported since
> > oVirt 3.4,
> 3.4.1, actually (see bug 1103679), but I agree, this is a regression.

:)

> Tal - let's have someone take a quick look please?
Comment 4 Eyal Edri 2015-10-14 11:39:52 EDT
fixed version & build id
Comment 5 Kevin Alon Goldblatt 2015-11-08 10:12:16 EST
Verified with the following code:
-------------------------------------------
vdsm-4.17.10.1-0.el7ev.noarch
rhevm-3.6.0.3-0.1.el6.noarch

Verified with the following scenario:
------------------------------------------
Steps to Reproduce:
1.have a vm + disk
2.start the vm
3.Edit the VM -> Disk >>>>> The Wipe After Delete Check button is enabled.
4.Check the Wipe After Delete checkbox and save >>>>> The change is saved.
5.Edit the Wipe After Delete checkbox again - uncheck the checkbox and save >>>>> The change is saved.

Moving to VERIFIED!
Comment 7 Allon Mureinik 2016-03-10 05:34:43 EST
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE
Comment 8 Allon Mureinik 2016-03-10 05:36:43 EST
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE
Comment 9 Allon Mureinik 2016-03-10 05:42:19 EST
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE
Comment 10 Allon Mureinik 2016-03-10 06:59:12 EST
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.