Bug 125891 - useradd during %post locks group file
Summary: useradd during %post locks group file
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-13 11:59 UTC by Daniel McNamara
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-25 14:20:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel McNamara 2004-06-13 11:59:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
Running a kickstart install and trying to do a useradd as part of the
%post

useradd succeds mostly but something during it causts the /etc/group
file to be locked and the users group is not added succesfully. Also
makes adding any other user/groups after the fact almost impossible as
the group file (and corresponding shadow file) remain locked after the
install.

Version-Release number of selected component (if applicable):
anaconda-10.0-5

How reproducible:
Always

Steps to Reproduce:
1. Create a kickstart config - Add a useradd command in %post
2. Run the kickstart install. Should succedd without errors
3. Check the system upon reboot
    

Actual Results:  /etc/group file will be locked
Confirmed by prescence /etc/group.lock
Adding further groups will fail due to lock
The users group will not exist either

Expected Results:  users group should be added
group file should not be locked
Adding groups should not be failed by group.lock

Additional info:

Tested with also changing the useradd to set users primary group as an
existing group. Also fails and results in the group file lock.

Comment 1 Philip Balister 2004-06-25 20:23:08 UTC
I installed FC2 and then tried adding a user. Ran into the group file
locked message. The group entry for the user I added during install is
in the group file. I removed /etc/group.lock and then successfully
added a new user with useradd.

Comment 2 Warren Togami 2004-08-24 12:31:59 UTC
Mid-September please verify if this is still an issue with FC3 Test2.


Note You need to log in before you can comment on or make changes to this bug.