Bug 125894 - kernel 2.6.6-1.427 usb driver problems on nForce2
kernel 2.6.6-1.427 usb driver problems on nForce2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-13 08:24 EDT by James Smith
Modified: 2015-01-04 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 03:18:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output on functional 2.6.5 system (13.66 KB, text/plain)
2004-06-13 08:25 EDT, James Smith
no flags Details
dmesg output on broken 2.6.6 system (13.04 KB, text/plain)
2004-06-13 08:25 EDT, James Smith
no flags Details
lsusb and /proc/bus/usb/devices for both 2.6.5 and 2.6.6 kernels (1.62 KB, text/plain)
2004-06-13 08:28 EDT, James Smith
no flags Details
lsmod output after normal boot for both 2.6.5 and 2.6.6 kernels (2.57 KB, text/plain)
2004-06-13 08:29 EDT, James Smith
no flags Details
lsusb and /proc/bus/usb/devices output for both 2.6.5 and 2.6.6 kernels (5.08 KB, text/plain)
2004-06-13 08:31 EDT, James Smith
no flags Details

  None (edit)
Description James Smith 2004-06-13 08:24:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20040323 Galeon/1.3.7

Description of problem:
After upgrading from kernel-2.6.5-1.358 to kernel-2.6.6-1.427, various
drivers fail to work correctly. Most obvious is the USB system, which
fails to recognise my USB mouse and joystick. Sound support also seems
to fail. Upon rebooting to the 2.6.5 kernel, all devices function
normally again.

I will paste dmesg, lsusb, /proc/bus/usb/devices and lsmod output as
attachments below.

Hardware information:

Motherboard: nForce 2 (AOpen AK79D-1394)
RAM: 512M

/proc/cpuinfo:
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 8
model name      : AMD Athlon(tm) XP 2200+
stepping        : 0
cpu MHz         : 1803.867
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca
cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow
bogomips        : 3571.71

uname -a: 
Linux ford.bartonplace.net 2.6.5-1.358 #1 Sat May 8 09:04:50 EDT 2004
i686 athlon i386 GNU/Linux

Version-Release number of selected component (if applicable):
kernel 2.6.6-1.427

How reproducible:
Always

Steps to Reproduce:
1. Boot machine with kernel 2.6.6
2. Wait for boot process to complete
    

Actual Results:  Non-functional USB mouse, also Saitek Cyborg joystick
is missing from lsusb, and sound modules appear to not be loaded.

Expected Results:  Things working with no problems, as they did under
2.6.5 :)

Additional info:
Comment 1 James Smith 2004-06-13 08:25:25 EDT
Created attachment 101092 [details]
dmesg output on functional 2.6.5 system
Comment 2 James Smith 2004-06-13 08:25:58 EDT
Created attachment 101093 [details]
dmesg output on broken 2.6.6 system
Comment 3 James Smith 2004-06-13 08:28:08 EDT
Created attachment 101094 [details]
lsusb and /proc/bus/usb/devices for both 2.6.5 and 2.6.6 kernels
Comment 4 Arjan van de Ven 2004-06-13 08:28:21 EDT
if you add "acpi=off" to the kernel commandline, does that improve things?
(to do this just hit "a" in the grub menu and edit the vmlinuz line)
Comment 5 James Smith 2004-06-13 08:29:12 EDT
Created attachment 101095 [details]
lsmod output after normal boot for both 2.6.5 and 2.6.6 kernels
Comment 6 James Smith 2004-06-13 08:31:25 EDT
Created attachment 101096 [details]
lsusb and /proc/bus/usb/devices output for both 2.6.5 and 2.6.6 kernels

Sorry, uploaded wrong file before
Comment 7 James Smith 2004-06-13 08:53:28 EDT
Unfortunately, the "acpi=off" kernel parameter seems to make no
discernible difference. Sorry!
Comment 8 Scott Sloan 2004-06-17 14:54:11 EDT
I get have this same problem with an nforce board. however I notice
during booting.

ehci_hcd 0000:00:02.2: new USB bus registered, assigned bus number 1
irq 5: nobody cared! (screaming interrupt?)
Stack pointer is garbage, not printing trace
handlers:
[<022169f4>] (usb_hcd_irq+0x0/0x4b)
Disabling IRQ #5
Comment 9 James Smith 2004-06-18 03:46:50 EDT
The same message appears in my 2.6.6 dmesg output attached below, 
except for me it's irq 10. Does your onboard soundcard (if you're 
using it) work under the new kernel, or is it just USB that's giving 
you problems?
Comment 10 Scott Sloan 2004-06-18 08:08:58 EDT
In short, no my onboard soundcard doesn't work. This is quite
entertaining and something I did not think to look at until you
mention it. My on board soundcard although It is disabled in the bios,
is detected and installed in Linux. However neither my onboard sound
card nor my Audigy soundcard works with this kernel. I will get a tone
and then a pause and then a tone ...etc leading to the program locking
up. 

Comment 11 Vaclav "sHINOBI" Misek 2004-07-02 02:36:36 EDT
I can confirm this behaviour with kernel kernel-2.6.7-1.459 as well.
This conflict also makes a problem with new NVIDIA drivers (1.0-6106),
I need to disable USB in BIOS (or maybe set it to 1.1 only, I haven't
tried this setting yet) to make it working. Onboard sound is working
without probs for me. There is one strange thing. There is no such
problem on my second computer and no error message according to the
USB subsystem. Same chipset, motherboard and kernel :-o
Comment 12 Boris Glawe 2004-07-08 14:49:40 EDT
I can confirm this bug ! My USB-Stick does not work any more since the
upgrade from 2.6.5-whatever to 2.6.6-435.

I have an Asus nforce2 Board with Athlon XP 2800.

The Stick responds with blinking LED at startup, the kernel boots
fine. And at a quiet random point during the the startup-skripts, the
LED switches off.

Trying to mount the stick results in "invalid block device". There are
no usb-storage specific drivers loaded.

acip=off does not work

My USB-mouse works fine


greets Boris

here an excperpt from my /var/log/messages


Jul  7 16:50:38 muli kernel: ehci_hcd 0000:00:02.2: EHCI Host Controller
> Jul  7 16:50:38 muli kernel: ehci_hcd 0000:00:02.2: irq 11, pci mem
2286c000
> Jul  7 16:50:38 muli kernel: ehci_hcd 0000:00:02.2: new USB bus
registered,
> assigned bus number 1
> Jul  7 16:50:38 muli kernel: irq 11: nobody cared! (screaming
interrupt?)
> Jul  7 16:50:38 muli kernel: Stack pointer is garbage, not printing
trace
> Jul  7 16:50:38 muli kernel: handlers:
> Jul  7 16:50:38 muli kernel: [<02216a08>] (usb_hcd_irq+0x0/0x4b)
> Jul  7 16:50:38 muli kernel: Disabling IRQ #11
> Jul  7 16:50:38 muli kernel: ehci_hcd 0000:00:02.2: USB 2.0 enabled,
> EHCI 1.00, driver 2004-May-10
Comment 13 David Mulligan 2004-07-15 11:34:43 EDT
Some interesting comments on this issue can be found at
http://kerneltrap.org/node/view/3373
Comment 14 James Smith 2004-07-17 07:16:09 EDT
As suggested by the above link, I've upgraded to the Fedora Core 3
Test 1 kernel, kernel-2.6.7-1.478, and everything is working fine again.
Comment 15 Vaclav "sHINOBI" Misek 2004-07-17 17:26:32 EDT
I can confirm, that kernel-2.6.7-1.492 fixes this problem for me as
well. I suppose this bug should be closed.
Comment 16 David Mulligan 2004-07-18 14:46:09 EDT
I hope not until a new kernel, even this one, is released for FC2.
Comment 17 Dave Jones 2004-11-27 15:19:57 EST
mass update for old bugs:

Is this still a problem with the 2.6.9 based update kernel ?
Comment 18 James Smith 2004-11-27 16:00:44 EST
I'm on the latest FC3 kernel now, kernel-2.6.9-1.681_FC3, and everything is good.

Note You need to log in before you can comment on or make changes to this bug.