Bug 1258974 - mate-mouse-properties has no noticable effect
mate-mouse-properties has no noticable effect
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: mate-control-center (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 11:57 EDT by John Cox
Modified: 2016-07-19 15:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 15:17:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Cox 2015-09-01 11:57:34 EDT
Description of problem:
changing sensitivity or accel settings using mate-mouse-properties has no effect

Version-Release number of selected component (if applicable):

mate control center 1.10.1-1

How reproducible:


Steps to Reproduce:
1.open mouse control app
2.change sensitivity and accel settings from min to max
3.observe no change in cursor behaviour

Actual results: no change in mouse behaviour
modifying via dconf has no impact either.
Changes to dconf do change the indicator positions in mate-mouse-properties but still no change of the  on screen behaviour of the mouse.


Expected results:

changes from max to should make obvious changes in behavior.

Additional info:

This is with a no frills usb mouse
Comment 1 John Cox 2015-09-01 12:19:47 EDT
modifying via xinput works.
Comment 2 Wolfgang Ulbrich 2015-09-01 13:02:14 EDT
Did you try out login/logout from session?
There is a glib2 regression which breaks gsettings keys, in result you need to reloggin for applying settings.
Some gsettings keys are fixed by mate upstream but not all.
Note, those breakage is revert in glib master.
https://github.com/mate-desktop/eom/commit/971e627c6f066393b282f5d0182daaa0084e6e9a

So, please can you confirm?
Comment 3 John Cox 2015-09-01 13:30:17 EDT
I don't see any difference when logging in/out after changes.
At least not as obvious as changing xinput --set-prop "Logitech USB-PS/2 Optical Mouse" "libinput Accel Speed" 1 to -1.
Comment 4 Wolfgang Ulbrich 2015-09-01 14:25:47 EDT
Hmm,
can you please install glib2 from https://copr.fedoraproject.org/coprs/leigh123linux/glib2/
for testing?
Here the culprit commit is reverted.
I use this glib2 version too and i can change the values for my mouse device during session.
Btw. Do you use mate in a VM or on bare metal?
Comment 5 John Cox 2015-09-01 15:08:04 EDT
Still no change with this glib2 change.
I am not using this in a VM.
Comment 6 John Cox 2015-09-19 11:24:03 EDT
What do you mean this is not a bug?
It doesn't work on my laptop or desktop.
I can change settings via xinput but not by using this mate app.
Comment 7 Wolfgang Ulbrich 2015-09-20 18:14:23 EDT
(In reply to John Cox from comment #6)
> What do you mean this is not a bug?
No, but i can't reproduce it on my boxes wit several devices.
So it's hard to find a solution. Maybe it's a hardware related problem and mate-mouse-properties does not support your device.
Honestly, my knowledge about mouse devices is limited and i don't know how mate-mouse-properties gets information from mouse driver.
You can open a report at upstream, hopefully those guy knows to debug it.
https://github.com/mate-desktop/mate-control-center
Comment 8 Wolfgang Ulbrich 2015-11-01 07:03:15 EST
I found this post at mate forum.
Maybe this worharound helps?
http://forums.mate-desktop.org/viewtopic.php?f=2&t=3324
see notes.
Comment 9 Fedora End Of Life 2016-07-19 15:17:59 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.