Bug 125899 - File dialog hangs openoffice about half the times it is used
File dialog hangs openoffice about half the times it is used
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-13 11:59 EDT by Alan Cox
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-25 17:07:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2004-06-13 11:59:43 EDT
While FC1 open office was reliable the FC2 test open office kept
hanging in the file dialog box, as it does in FC2 final. I've been
trying to figure out what may be making the difference. I'm mostly
seeing the problem on the following setup

VIA C3 (i586 equivalent)
Directory on NFS (contains about 800 files)

I see the problem both from "print to file" and "save as" dialog
boxes.  I am given a dialog box for file choice. At the point I hit
enter having completed the file name openoffice hangs.
Comment 1 Dan Williams 2004-06-14 09:07:45 EDT
Can you do this when it hangs?

1) Grab the PID of OOo from a terminal ('ps -aux | grep soffice.bin'
and grab the left-most number)
2) 'gdb'
3) 'attach <number from step 1>'
4) 't a a bt'

and then post that output here.  Thanks!
Comment 2 Dan Williams 2004-06-14 09:08:10 EDT
eh, sorry for the detailed instructions Alan... standard response :)
Comment 3 Alan Cox 2004-06-14 09:46:44 EDT
Here you are:

alan      4812 36.2 11.2 124272 57076 pts/22 S    13:39   0:24
/usr/lib/ooo-1.1/program/soffice.bin -writer
alan      4829  0.0 11.2 124272 57076 pts/22 S    13:39   0:00
/usr/lib/ooo-1.1/program/soffice.bin -writer
alan      4830  0.0 11.2 124272 57076 pts/22 S    13:39   0:00
/usr/lib/ooo-1.1/program/soffice.bin -writer
alan      4831  0.2 11.2 124272 57076 pts/22 S    13:39   0:00
/usr/lib/ooo-1.1/program/soffice.bin -writer
alan      4833  0.0 11.2 124272 57076 pts/22 S    13:39   0:00
/usr/lib/ooo-1.1/program/soffice.bin -writer
alan      4836  0.0 11.2 124272 57076 pts/22 S    13:39   0:00
/usr/lib/ooo-1.1/program/soffice.bin -writer
alan      4839  0.0 11.2 124272 57076 pts/22 S    13:40   0:00
/usr/lib/ooo-1.1/program/soffice.bin -writer

Thread 7 (Thread 98311 (LWP 4839)):
#0  0x009edf5c in __pthread_sigsuspend () from /lib/libpthread.so.0
#1  0x009ed76d in __pthread_wait_for_restart_signal ()
   from /lib/libpthread.so.0
#2  0x009ef674 in __pthread_lock () from /lib/libpthread.so.0
#3  0x009ec229 in pthread_mutex_lock () from /lib/libpthread.so.0
#4  0x007658fb in osl_acquireMutex () from
/usr/lib/ooo-1.1/program/libsal.so.3
#5  0x0055fb66 in vos::OMutex::acquire ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#6  0x003bec60 in SalYieldMutex::acquire ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#7  0x02f5ab40 in framework::LockHelper::acquireReadAccess ()
   from /usr/lib/ooo-1.1/program/libfwi645li.so
#8  0x01dfa7c0 in component_getFactory ()
   from /usr/lib/ooo-1.1/program/libfwl645li.so
#9  0x01dfd3c5 in component_getFactory ()
   from /usr/lib/ooo-1.1/program/libfwl645li.so
#10 0x006fd591 in cppu::OPropertySetHelper::getFastPropertyValue ()
   from /usr/lib/ooo-1.1/program/libcppuhelpergcc3.so.3
#11 0x005ff307 in SvtPathOptions_Impl::GetPath ()
   from /usr/lib/ooo-1.1/program/libsvl645li.so
#12 0x00602c79 in SvtPathOptions::GetWorkPath ()
   from /usr/lib/ooo-1.1/program/libsvl645li.so
#13 0x00f171d0 in SvtMatchContext_Impl::run ()
   from /usr/lib/ooo-1.1/program/libsvt645li.so
#14 0x00564db2 in vos::_cpp_OThread_WorkerFunction ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#15 0x00564d97 in _OThread_WorkerFunction ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#16 0x0076632b in osl_getSystemLocale ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#17 0x009eb6eb in pthread_start_thread () from /lib/libpthread.so.0
#18 0x089e1e8a in clone () from /lib/libc.so.6
 
Thread 6 (Thread 65541 (LWP 4836)):
#0  0x009edf5c in __pthread_sigsuspend () from /lib/libpthread.so.0
#1  0x009ed76d in __pthread_wait_for_restart_signal ()
   from /lib/libpthread.so.0
#2  0x009ef674 in __pthread_lock () from /lib/libpthread.so.0
#3  0x009ec229 in pthread_mutex_lock () from /lib/libpthread.so.0
#4  0x007658fb in osl_acquireMutex () from
/usr/lib/ooo-1.1/program/libsal.so.3
#5  0x0055fb66 in vos::OMutex::acquire ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#6  0x003bec60 in SalYieldMutex::acquire ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#7  0x41410d89 in CreateObjSwWebDocShellDll ()
   from /usr/lib/ooo-1.1/program/libsw645li.so
#8  0x01fd1417 in ?? () from /usr/lib/ooo-1.1/program/libdtransX11645li.so
#9  0x01fd1c8d in ?? () from /usr/lib/ooo-1.1/program/libdtransX11645li.so
#10 0x01fe57ce in ?? () from /usr/lib/ooo-1.1/program/libdtransX11645li.so
#11 0x0076632b in osl_getSystemLocale ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#12 0x009eb6eb in pthread_start_thread () from /lib/libpthread.so.0
#13 0x089e1e8a in clone () from /lib/libc.so.6
 
Thread 5 (Thread 49156 (LWP 4833)):
#0  0x089d994a in poll () from /lib/libc.so.6
#1  0x003c74d2 in ICEConnectionWorker ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#2  0x0076632b in osl_getSystemLocale ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#3  0x009eb6eb in pthread_start_thread () from /lib/libpthread.so.0
#4  0x089e1e8a in clone () from /lib/libc.so.6
 
Thread 4 (Thread 32771 (LWP 4831)):
#0  0x009f2166 in nanosleep () from /lib/libpthread.so.0
#1  0x00000001 in ?? ()
#2  0x009ed8a3 in __pthread_timedsuspend_new () from /lib/libpthread.so.0
#3  0x009ea144 in pthread_cond_timedwait_relative () from
/lib/libpthread.so.0
#4  0x00762d33 in osl_waitCondition ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#5  0x0055e3fd in vos::OCondition::wait ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#6  0x00568410 in vos::OTimerManager::run ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#7  0x00564db2 in vos::_cpp_OThread_WorkerFunction ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#8  0x00564d97 in _OThread_WorkerFunction ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#9  0x0076632b in osl_getSystemLocale ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#10 0x009eb6eb in pthread_start_thread () from /lib/libpthread.so.0
#11 0x089e1e8a in clone () from /lib/libc.so.6
 
Thread 3 (Thread 16386 (LWP 4830)):
#0  0x009f1b98 in accept () from /lib/libpthread.so.0
#1  0x007712c6 in osl_acceptPipe () from
/usr/lib/ooo-1.1/program/libsal.so.3
#2  0x0056b28e in vos::OPipe::accept ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#3  0x0806f07d in desktop::OfficeIPCThread::run ()
#4  0x00564db2 in vos::_cpp_OThread_WorkerFunction ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#5  0x00564d97 in _OThread_WorkerFunction ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#6  0x0076632b in osl_getSystemLocale ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#7  0x009eb6eb in pthread_start_thread () from /lib/libpthread.so.0
#8  0x089e1e8a in clone () from /lib/libc.so.6
 
Thread 2 (Thread 32769 (LWP 4829)):
#0  0x089d994a in poll () from /lib/libc.so.6
#1  0x009eaa8f in __pthread_manager () from /lib/libpthread.so.0
#2  0x089e1e8a in clone () from /lib/libc.so.6
 
Thread 1 (Thread 16384 (LWP 4812)):
#0  0x009edf5c in __pthread_sigsuspend () from /lib/libpthread.so.0
#1  0x009ed76d in __pthread_wait_for_restart_signal ()
   from /lib/libpthread.so.0
#2  0x009ef674 in __pthread_lock () from /lib/libpthread.so.0
#3  0x009ec229 in pthread_mutex_lock () from /lib/libpthread.so.0
#4  0x007658fb in osl_acquireMutex () from
/usr/lib/ooo-1.1/program/libsal.so.3
#5  0x0055fb66 in vos::OMutex::acquire ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#6  0x00f19650 in SvtURLBox::ProcessKey ()
   from /usr/lib/ooo-1.1/program/libsvt645li.so
#7  0x00f19a9f in SvtURLBox::PreNotify ()
   from /usr/lib/ooo-1.1/program/libsvt645li.so
#8  0x0031bd00 in Window::PreNotify ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#9  0x00327398 in ImplCallPreNotify ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#10 0x00329230 in ImplHandleMouseEvent ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#11 0x0032b5b5 in ImplWindowFrameProc ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#12 0x0038bbec in SalFrameData::HandleKeyEvent ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#13 0x0038d69e in SalFrameData::Dispatch ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#14 0x003bbbdc in SalDisplay::Dispatch ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#15 0x003bb917 in SalDisplay::Yield ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#16 0x003b751f in SalDisplay::~SalDisplay ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#17 0x003b5f6c in SalXLib::Yield ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#18 0x003bf202 in SalInstance::Yield ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#19 0x001de6b7 in Application::Yield ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#20 0x002d71c3 in Dialog::Execute ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#21 0x00f264e1 in SvtFileDialog::Execute ()
   from /usr/lib/ooo-1.1/program/libsvt645li.so
#22 0x00f0e16b in SvtFilePicker::implExecutePicker ()
   from /usr/lib/ooo-1.1/program/libsvt645li.so
#23 0x00f33f07 in svt::OCommonPicker::execute ()
   from /usr/lib/ooo-1.1/program/libsvt645li.so
#24 0x00f0e5fc in SvtFilePicker::execute ()
   from /usr/lib/ooo-1.1/program/libsvt645li.so
#25 0x05d4d03c in sfx2::FileDialogHelper_Impl::implDoExecute ()
   from /usr/lib/ooo-1.1/program/libsfx645li.so
#26 0x05d4d254 in sfx2::FileDialogHelper_Impl::execute ()
   from /usr/lib/ooo-1.1/program/libsfx645li.so
#27 0x05d52a1d in sfx2::FileDialogHelper::Execute ()
   from /usr/lib/ooo-1.1/program/libsfx645li.so
#28 0x05c347fb in SfxObjectShell::GUISaveAs_Impl ()
   from /usr/lib/ooo-1.1/program/libsfx645li.so
#29 0x05c39592 in SfxObjectShell::ExecFile_Impl ()
   from /usr/lib/ooo-1.1/program/libsfx645li.so
#30 0x05c32816 in SfxStubSfxObjectShellExecFile_Impl ()
   from /usr/lib/ooo-1.1/program/libsfx645li.so
#31 0x05cd3f16 in SfxDispatcher::Call_Impl ()
   from /usr/lib/ooo-1.1/program/libsfx645li.so
#32 0x05cd5368 in SfxDispatcher::_Execute ()
   from /usr/lib/ooo-1.1/program/libsfx645li.so
#33 0x05ce54ba in SfxBindings::Execute_Impl ()
   from /usr/lib/ooo-1.1/program/libsfx645li.so
#34 0x05ce5090 in SfxBindings::Execute_Impl ()
   from /usr/lib/ooo-1.1/program/libsfx645li.so
#35 0x05ce4c43 in SfxBindings::Execute ()
   from /usr/lib/ooo-1.1/program/libsfx645li.so
#36 0x05d022d6 in SfxVirtualMenu::Select ()
   from /usr/lib/ooo-1.1/program/libsfx645li.so
#37 0x05d01d7c in SfxVirtualMenu::LinkStubSelect ()
   from /usr/lib/ooo-1.1/program/libsfx645li.so
#38 0x002dea8e in Menu::Select () from
/usr/lib/ooo-1.1/program/libvcl645li.so
#39 0x002e286c in Menu::ImplCallSelect ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#40 0x002e284c in Menu::LinkStubImplCallSelect ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#41 0x0032afae in ImplHandleClose ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#42 0x0032b806 in ImplWindowFrameProc ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#43 0x0038cfb1 in SalFrameData::HandleClientMessage ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#44 0x0038db66 in SalFrameData::Dispatch ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#45 0x003bbbdc in SalDisplay::Dispatch ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#46 0x003bb917 in SalDisplay::Yield ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#47 0x003b751f in SalDisplay::~SalDisplay ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#48 0x003b5ed7 in SalXLib::Yield ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#49 0x003bf202 in SalInstance::Yield ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#50 0x001de6b7 in Application::Yield ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#51 0x001de5c9 in Application::Execute ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#52 0x08065100 in desktop::Desktop::Main ()
#53 0x001e31f7 in SVMain () from /usr/lib/ooo-1.1/program/libvcl645li.so
#54 0x003b48ac in main () from /usr/lib/ooo-1.1/program/libvcl645li.so
#55 0x0894af55 in __libc_start_main () from /lib/libc.so.6
#56 0x0805ded9 in _start ()
#0  0x009edf5c in __pthread_sigsuspend () from /lib/libpthread.so.0
(gdb)



Comment 4 Dan Williams 2004-09-25 17:07:20 EDT
should be fixed in 1.1.2-5 since we use GNOME open/save dialog now
Comment 6 Marty Wesley 2005-05-26 02:58:07 EDT
PM ACK for U2.

Note You need to log in before you can comment on or make changes to this bug.