Bug 1259071 - oo-install seems to never validate SSH connections to endpoints.
oo-install seems to never validate SSH connections to endpoints.
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
2.2.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Timothy Williams
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 18:08 EDT by Eric Rich
Modified: 2016-07-03 20:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-18 17:46:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Rich 2015-09-01 18:08:28 EDT
Description of problem:

Hostname / IP address for SSH access to ose-node1.paas.it from the
host where you are running oo-install. You can say 'localhost' if you
are running oo-install from the system that you are describing:
|ose-node1.paas.it| 192.168.110.3

Username for SSH access to 192.168.110.3: |root| root

Validating root@192.168.110.3... 
Could not connect to 192.168.110.3 with user root.
The SSH attempt yielded the following error:
"root"
Comment 3 Timothy Williams 2016-03-28 16:52:56 EDT
I'm sorry Eric, what are you asking for here? It looks like oo-install is checking for connectivity to the endpoint with the user-provided information. Are you looking for better error output?
Comment 4 Eric Rich 2016-04-18 17:46:18 EDT
(In reply to Timothy Williams from comment #3)
> I'm sorry Eric, what are you asking for here? It looks like oo-install is
> checking for connectivity to the endpoint with the user-provided
> information. Are you looking for better error output?

Tim I think one of the issues here is that the reporting is bad, on what you are connecting to. In the output we only report 'root', so it makes me wonder if we are event trying to connect to the 'ose-node1.paas.it' or '192.168.110.3' addresses. 

That being said, I think this is a low, issue that has workarounds, by providing keys and specifying connection endpoints.

Note You need to log in before you can comment on or make changes to this bug.