Bug 1259186 - Improper error message reported when trying to add RHEL6.7 host to 3.6 default host cluster | Host <FQDN of the host> installation failed. Command returned failure code 1 during SSH session 'root@<FQDN of the host>'.
Improper error message reported when trying to add RHEL6.7 host to 3.6 defaul...
Status: CLOSED DUPLICATE of bug 1261788
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: nobody nobody
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 03:19 EDT by Nikolai Sednev
Modified: 2015-09-10 05:22 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-10 05:22:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine logs (293.84 KB, application/x-gzip)
2015-09-02 03:24 EDT, Nikolai Sednev
no flags Details

  None (edit)
Description Nikolai Sednev 2015-09-02 03:19:30 EDT
Description of problem:
Improper error message reported when trying to add RHEL6.7 host to 3.6 default host cluster | Host <FQDN of the host> installation failed. Command returned failure code 1 during SSH session 'root@<FQDN of the host>'.

I've tried to add RHEL6.7 host to RHEVM3.6 default HC with 3.6 compatibility.
Host shouldn't be added to such host cluster as OSs lower than RHEL7.2 should not be added to HC3.6 and above. The result of adding the host was OK, except for incorrect error message being reported.
 
Version-Release number of selected component (if applicable):
On engine:
qemu-guest-agent-0.12.1.2-2.479.el6.x86_64
rhevm-3.6.0-0.12.master.el6.noarch
ovirt-vmconsole-1.0.0-0.0.master.el6ev.noarch


How reproducible:
100%

Steps to Reproduce:
1.Install fresh installation of RHEL6.7 on VM.
2.Install latest ovirt-vmconsole on VM.
3.Install RHEVM3.6 on VM. 
4.engine-setup on VM.
5.Install fresh RHEL6.7 on host.
6.Add host to default HC in RHEVM.

Actual results:
Host not added to RHEVM3.6 default 3.6 compatible host cluster with the error "Host <FQDN of the host> installation failed. Command returned failure code 1 during SSH session 'root@<FQDN of the host>'.".

Expected results:
Host not added to RHEVM3.6 default 3.6 compatible host cluster, but with meaningful error message, something like "Host's OS is lower than RHEL/RHEVH7.2" or "Incompatible OS on host".

Additional info:
logs from the engine
Comment 1 Nikolai Sednev 2015-09-02 03:24:07 EDT
Created attachment 1069276 [details]
engine logs
Comment 2 meital avital 2015-09-10 05:22:07 EDT
Closing this bug. new bug opened with clarified information.

*** This bug has been marked as a duplicate of bug 1261788 ***

Note You need to log in before you can comment on or make changes to this bug.