Bug 1259195 - bash: [: |/usr/bin/lesspipe.sh : opérateur binaire attendu
bash: [: |/usr/bin/lesspipe.sh : opérateur binaire attendu
Status: CLOSED DUPLICATE of bug 1258808
Product: Fedora
Classification: Fedora
Component: less (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Viktor Jancik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 03:36 EDT by Nicolas Mailhot
Modified: 2016-01-31 21:25 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-02 07:21:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2015-09-02 03:36:43 EDT
Description of problem:
bash: [: |/usr/bin/lesspipe.sh : opérateur binaire attendu

when starting bash

caused by something in /etc/bashrc (removing /etc/bashrc sourcing in ~/.bashrc removes the warning)

Version-Release number of selected component (if applicable):

setup-2.9.8-2.fc23.noarch
bash-4.3.42-1.fc24.x86_64
Comment 1 Kamil Dudka 2015-09-02 07:16:26 EDT
This seems to be caused by missing quotes in /etc/profile.d/less.sh which was changed recently:

http://pkgs.fedoraproject.org/cgit/less.git/commit/?id=b539f87a

The following patch will fix it:

--- a/less.sh
+++ b/less.sh
@@ -1,4 +1,4 @@
 # less initialization script (sh)
-if [ -x /usr/bin/lesspipe.sh ] && [ -z $LESSOPEN ]; then
+if [ -x /usr/bin/lesspipe.sh ] && [ -z "$LESSOPEN" ]; then
     export LESSOPEN="|/usr/bin/lesspipe.sh %s"
 fi
Comment 2 Yanko Kaneti 2015-09-02 07:21:04 EDT

*** This bug has been marked as a duplicate of bug 1258808 ***

Note You need to log in before you can comment on or make changes to this bug.