Bug 1259396 - perl-MooseX-LazyLogDispatch-0.02-18.fc24 FTBFS: tests fail with recent perl-Log-Dispatch
perl-MooseX-LazyLogDispatch-0.02-18.fc24 FTBFS: tests fail with recent perl-L...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: perl-MooseX-LazyLogDispatch (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Emmanuel Seyman
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 10:02 EDT by Petr Pisar
Modified: 2015-09-13 05:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-13 05:41:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2015-09-02 10:02:56 EDT
perl-MooseX-LazyLogDispatch-0.02-18.fc24 fails to build in F24 because tests fail:

+ make test
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/01use.t t/10simple.t
t/01use.t ..... ok
#   Failed test 'Got correct errors to stderr'
#   at t/10simple.t line 86.
#          got: undef
#     expected: '[info] foo at t/10simple.t line 13
# [error] Gah! at t/10simple.t line 14
# '
[info] foo at t/10simple.t line 13
[error] Gah! at t/10simple.t line 14
#   Failed test 'Got correct errors to stderr'
#   at t/10simple.t line 105.
#          got: undef
#     expected: '[info] foo all custom-like
# [error] Gah! all custom-like
# '
[info] foo all custom-like
[error] Gah! all custom-like
#   Failed test 'Got correct errors to stderr'
#   at t/10simple.t line 124.
#          got: undef
#     expected: '[info] foo (config via subclass)
# [error] Gah! (config via subclass)
# '
# Looks like you failed 3 tests of 9.
[info] foo (config via subclass)
[error] Gah! (config via subclass)
t/10simple.t .. 
Dubious, test returned 3 (wstat 768, 0x300)
Failed 3/9 subtests 

Difference between working and failing build root is:

        perl-Log-Dispatch 	2.44-3.fc23 	> 	2.48-1.fc24
	perl-libs 	4:5.22.0-349.fc24 	> 	4:5.22.0-350.fc24
	perl 	4:5.22.0-349.fc24 	> 	4:5.22.0-350.fc24
	perl-macros 	4:5.22.0-349.fc24 	> 	4:5.22.0-350.fc24
	perl-devel 	4:5.22.0-349.fc24 	> 	4:5.22.0-350.fc24
	rpm-build 	4.12.90-5.fc24 	> 	4.12.90-6.fc24
	rpm-plugin-systemd-inhibit 	4.12.90-5.fc24 	> 	4.12.90-6.fc24
	rpm-libs 	4.12.90-5.fc24 	> 	4.12.90-6.fc24
	rpm-python3 	4.12.90-5.fc24 	> 	4.12.90-6.fc24
	perl-Storable 	1:2.53-346.fc23 	< 	
	kernel-headers 	4.2.0-0.rc5.git2.1.... 	> 	4.2.0-0.rc5.git3.1....
	perl-Time-HiRes 	1.9726-346.fc23 	< 	
	rpm-build-libs 	4.12.90-5.fc24 	> 	4.12.90-6.fc24
	rpm 	4.12.90-5.fc24 	> 	4.12.90-6.fc24
	rpm-plugin-selinux 	4.12.90-5.fc24 	> 	4.12.90-6.fc24
Comment 1 Emmanuel Seyman 2015-09-13 05:41:06 EDT
Fixed with an update of perl-Log-Dispatch to 2.50

Note You need to log in before you can comment on or make changes to this bug.