Bug 125948 - "child setpgid" bash errors after upgrading glibc
"child setpgid" bash errors after upgrading glibc
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-14 10:20 EDT by Jonathan Kamens
Modified: 2007-04-18 13:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 21:47:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2004-06-14 10:20:45 EDT
After upgrading to glibc-2.3.3-31.1, I get messages like this every 
time I run a command in bash:

-bash: child setpgid (4602 to 46092): No such process

Downgrading to glibc-2.3.3-31 made the problem go away.

It appears that the new glibc also made "service start syslog" hang 
while trying to start syslogd.  After downgrading glibc I was able to 
start the syslog service with no trouble.
Comment 1 Jakub Jelinek 2004-06-14 10:52:47 EDT
Whar architecture?
I cannot reproduce this.
Maybe strace/ltrace dumps of the failing bash would help.
Comment 2 Jonathan Kamens 2004-06-14 10:57:19 EDT
Pentium III Katmai 550MHz.  Dual processors.  Running all the current 
Raw Hide bits.  The machine on which the problem occurred is a semi-
production machine, so I can't really upgrade and downgrade glibc 
again to product a dump.  I'll try the next glibc version, and if it 
persists, I'll capture some dumps for you.

Note that I don't have selinux configured; that may be relevant.

Note furthermore that I don't have a Red Hat or 2.6 kernel -- I'm 
using 2.4.25-pac1.  This is probably more relevant :-).
Comment 3 Jonathan Kamens 2004-08-12 12:22:41 EDT
This is still broken in -39.  I realize that this may be a lower 
priority because I've got a nonstandard kernel, but (a) I thought 
Fedora was supposed to work with non-standard kernels, and (b) as 
noted in but 126936, I can't upgrade to the current Red Hat kernel 
beacuse when I do my machine locks up hard almost instantaneously.

I'm beggin' you, help me out here :-).
Comment 4 Ulrich Drepper 2004-10-01 03:02:50 EDT
We cannot help if you do not provide more information.  Look at the
strace output and if necessary attach it to this bug.  I see nothing
in the ChangeLogs from those days which can be attributed to the problem.
Comment 5 Jonathan Kamens 2004-10-02 22:39:11 EDT
The problem is gone in glibc-2.3.3-63.
Comment 6 Jonathan Kamens 2005-03-07 09:55:47 EST
It's back in glibc-2.3.4-12.  Wasn't present in glibc-2.3.4-10.
Comment 7 Ulrich Drepper 2005-04-28 21:47:29 EDT
I don't see any problem and there is no information available from the reporter.
 Closing.

Note You need to log in before you can comment on or make changes to this bug.