Bug 1259528 - The client does not trust certificates signed by custom CAs
The client does not trust certificates signed by custom CAs
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mirall (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 19:05 EDT by Randy Barlow
Modified: 2015-09-18 04:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-18 04:14:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Barlow 2015-09-02 19:05:50 EDT
Description of problem:
I seem to be experiencing the issue from upstream #2964[0] but on Fedora Rawhide instead of OSX.

I am able to use curl and openssl s_connect just fine with my host, but the ownCloud client complains with this message:

"The issuer certificate of a locally looked up certificate could not be found
No certificates could be verified"

I do not experience this issue on another machine running Fedora 22. Fedora 22 has mirall-1.7.1-2.fc22.x86_64 while Fedora Rawhide has mirall-1.8.0-3.fc23.x86_64. Both machines are configured to use the same OwnCloud server, and both of them have the same custom CA certificate installed using update-ca-trust.

I've filed this issue upstream[1].


Version-Release number of selected component (if applicable):
mirall-1.8.0-3.fc23.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Deploy an OwnCloud server with an SSL certificate signed by a custom CA.
2. Install the custom CA to a Fedora Rawhide machine.
3. Configure mirall on the Rawhide machine to connect to the server.

Actual results:
You will see the error above.

Expected results:
Mirall should trust the server's certificate.


Additional info:
[0] https://github.com/owncloud/client/issues/2964
[1] https://github.com/owncloud/client/issues/3739
Comment 1 Fedora Admin XMLRPC Client 2015-09-04 06:04:42 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Nikos Roussos 2015-09-18 04:14:02 EDT
This seems to be fixed on the latest version. If persists after updating please open bug against owncloud-client component.

Note You need to log in before you can comment on or make changes to this bug.