Bug 1259591 - beah 0.7.9 fails to install on RHEL7.0 and RHEL7.1 GA versions
beah 0.7.9 fails to install on RHEL7.0 and RHEL7.1 GA versions
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 21.0
: ---
Assigned To: matt jia
Dan Callaghan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 02:43 EDT by Dan Callaghan
Modified: 2015-09-17 00:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-17 00:54:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2015-09-03 02:43:54 EDT
Description of problem:
For beah 0.7.9 we built against RHEL7.2 buildroot, which means that the selinux policy module adds a requirement on the very latest RHEL7.2 selinux-policy version. This makes beah 0.7.9 fail to install on older RHEL7 releases (including 7.0 and 7.1 GA versions).

Version-Release number of selected component (if applicable):
beah-0.7.9-1.el7

How reproducible:
easy

Steps to Reproduce:
1. Provision RHEL 7.0 (RHEL-7.0-20140507.0) or 7.1 (RHEL-7.1-20150219.1)

Actual results:
Recipe aborts, because beah failed to install. In console.log:

+ yum -y install beah rhts-test-env beakerlib
[...]
Error: Package: beah-0.7.9-1.el7.noarch (beaker-harness)
           Requires: selinux-policy >= 3.13.1-23.el7_1.13
           Installed: selinux-policy-3.12.1-153.el7.noarch (@beaker-Workstation/7.0)
               selinux-policy = 3.12.1-153.el7

Expected results:
No selinux-policy requirement on the beah package. On RHEL7.0 the policy module will fail to install, but that is expected (see bug ). On RHEL7.1 onwards the policy module should install and work.

Additional info:
We need to commit a pre-built policy module (built against 7.1 GA selinux-policy) to the source tree and use that rather than building the policy module afresh each time. We have a similar setup in rhts-test-env for the rhts policy module already, for this same reason.
Comment 2 Dan Callaghan 2015-09-03 02:56:04 EDT
(In reply to Dan Callaghan from comment #0)
> Expected results:
> No selinux-policy requirement on the beah package. On RHEL7.0 the policy
> module will fail to install, but that is expected (see bug ).

Forgot to fill this in... I meant: https://bugzilla.redhat.com/show_bug.cgi?id=1149988#c46
Comment 3 matt jia 2015-09-08 01:52:32 EDT
On Gerrit:

   http://gerrit.beaker-project.org/#/c/4387/
Comment 6 Dan Callaghan 2015-09-17 00:54:47 EDT
Beaker 21.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.