Bug 1259623 - Build with lua support by default [NEEDINFO]
Build with lua support by default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Peter Hatina
Fedora Extras Quality Assurance
: FutureFeature, Reopened
: 1230286 1255553 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 04:27 EDT by Denis Leroy
Modified: 2017-04-24 08:54 EDT (History)
9 users (show)

See Also:
Fixed In Version: wireshark-2.2.6-2.fc27
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-24 08:54:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jpokorny: needinfo? (phatina)


Attachments (Terms of Use)
Fixed --with_lua for compat-lua (3.35 KB, patch)
2015-09-03 04:27 EDT, Denis Leroy
no flags Details | Diff
Spec patch for 1.12.7 and compat-lua deps (1.41 KB, patch)
2015-09-03 04:31 EDT, Denis Leroy
no flags Details | Diff
Spec patch for 2.2.5 and compat-lua deps (554 bytes, patch)
2017-04-21 04:02 EDT, Denis Leroy
no flags Details | Diff

  None (edit)
Description Denis Leroy 2015-09-03 04:27:30 EDT
Created attachment 1069651 [details]
Fixed --with_lua for compat-lua

Two things here:

1. wireshark should really be compiled with lua support by default. The lua lib is tiny (< 100k rpm) so the dependency pull is not an issue here. Many many wireshark plugins are written in lua, hence this support is quite important.

2. Fedora 22 ships with lua 5.3 while wireshark only supports lua <= 5.2. I'm attaching a patch to fix the compilation to use the compat-lua package. The patch is horrible, because of the problematic way lua is packaged on Fedora (not at all done with compat packages in mind). Note the patch was made for wireshark 1.12.7.


Also, if you're interested in having a co-maintainer for this package, let me know.
Comment 1 Denis Leroy 2015-09-03 04:31:16 EDT
Created attachment 1069652 [details]
Spec patch for 1.12.7 and compat-lua deps
Comment 2 Jan Pokorný 2016-04-07 16:06:22 EDT
+1 to enable Lua support

Rationale:
I am in the process of packaging booth for Fedora ([bug 1314865])
and the upstream provides a Lua-based dissector:
https://github.com/ClusterLabs/booth/blob/v1.0/script/wireshark-dissector.lua
Comment 4 Fedora End Of Life 2016-07-19 15:56:10 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 5 Peter Lemenkov 2016-12-07 10:26:00 EST
*** Bug 1230286 has been marked as a duplicate of this bug. ***
Comment 6 Peter Lemenkov 2016-12-07 10:26:09 EST
*** Bug 1255553 has been marked as a duplicate of this bug. ***
Comment 7 Denis Leroy 2017-04-21 04:02 EDT
Created attachment 1273218 [details]
Spec patch for 2.2.5 and compat-lua deps

Updated spec for wireshark 2.2.5. No longer need to patch the source, latest wireshark versions auto-detects lua-5.1 correctly.

Note You need to log in before you can comment on or make changes to this bug.