Bug 1259646 - Not compile
Not compile
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: arduino (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dennis Chen
Fedora Extras Quality Assurance
:
: 1288630 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 05:25 EDT by miguel rodriguez
Modified: 2015-12-22 16:14 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 16:14:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Out of my terminal when i launched the compiler from Arduino IDE (15.18 KB, text/plain)
2015-09-03 05:25 EDT, miguel rodriguez
no flags Details
Verbose Output of avr-gcc (3.63 KB, text/plain)
2015-11-05 05:56 EST, Matthew Sainsbury
no flags Details

  None (edit)
Description miguel rodriguez 2015-09-03 05:25:45 EDT
Created attachment 1069697 [details]
Out of my terminal when i launched the compiler from Arduino IDE

Description of problem:
I cant compile scketch by error in library??

Version-Release number of selected component (if applicable):
1.0.6

How reproducible:

always i can verify my scketch
Steps to Reproduce:
1.edit your sketch or load an example
2.click on verify button
3.compiler crash

Actual results:
It is very long, but this is a summary:
 This report would have more information with
  "Show verbose output during compilation"
  enabled in File > Preferences.
Arduino: 1.0.6 (Linux), Board: "Arduino Mega 2560 or Mega ADK"
/usr/lib/gcc/avr/5.1.0/../../../../avr/bin/ld: cannot find dev/atmega2560/crt1.o: No existe el fichero o el directorio
/usr/lib/gcc/avr/5.1.0/../../../../avr/bin/ld: cannot find dev/atmega2560/libdev.a: No existe el fichero o el directorio
collect2: error: ld returned 1 exit status

Expected results:

compile it
Additional info:
Add a serial output
Comment 1 miguel rodriguez 2015-09-03 05:31:59 EDT
bash-4.3$ lsusb
Bus 002 Device 004: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 003: ID 046d:c52e Logitech, Inc. MK260 Wireless Combo Receiver
Bus 004 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 004: ID 2341:0042 Arduino SA Mega 2560 R3 (CDC ACM)
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

I think is loaded in kernel??

bash-4.3$ lsmod
Module                  Size  Used by
cdc_acm                36864  0
bnep                   20480  2
bluetooth             483328  5 bnep
rfkill                 24576  2 bluetooth
fuse                   94208  3
xt_CHECKSUM            16384  1
ipt_MASQUERADE         16384  3
nf_nat_masquerade_ipv4    16384  1 ipt_MASQUERADE
tun                    28672  1
nf_conntrack_netbios_ns    16384  0
nf_conntrack_broadcast    16384  1 nf_conntrack_netbios_ns
ip6t_rpfilter          16384  1
ip6t_REJECT            16384  2
nf_reject_ipv6         16384  1 ip6t_REJECT
xt_conntrack           16384  22
ebtable_filter         16384  1
ebtable_broute         16384  1
bridge                114688  1 ebtable_broute
stp                    16384  1 bridge
llc                    16384  2 stp,bridge
ebtable_nat            16384  1
ebtables               32768  3 ebtable_broute,ebtable_nat,ebtable_filter
ip6table_security      16384  1
ip6table_nat           16384  1
nf_conntrack_ipv6      20480  12
nf_defrag_ipv6         36864  1 nf_conntrack_ipv6
nf_nat_ipv6            16384  1 ip6table_nat
ip6table_raw           16384  1
ip6table_mangle        16384  1
ip6table_filter        16384  1
ip6_tables             28672  5 ip6table_filter,ip6table_mangle,ip6table_security,ip6table_nat,ip6table_raw
iptable_security       16384  1
iptable_nat            16384  1
nf_conntrack_ipv4      16384  12
nf_defrag_ipv4         16384  1 nf_conntrack_ipv4
nf_nat_ipv4            16384  1 iptable_nat
nf_nat                 28672  3 nf_nat_ipv4,nf_nat_ipv6,nf_nat_masquerade_ipv4
nf_conntrack          106496  9 nf_conntrack_netbios_ns,nf_nat,nf_nat_ipv4,nf_nat_ipv6,xt_conntrack,nf_nat_masquerade_ipv4,nf_conntrack_broadcast,nf_conntrack_ipv4,nf_conntrack_ipv6
iptable_raw            16384  1
iptable_mangle         16384  1
snd_hda_codec_hdmi     49152  1
snd_hda_codec_via      20480  1
snd_hda_codec_generic    73728  1 snd_hda_codec_via
kvm_amd                65536  0
kvm                   499712  1 kvm_amd
ppdev                  20480  0
snd_hda_intel          36864  7
snd_hda_codec         126976  4 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_codec_generic,snd_hda_intel
snd_hda_core           61440  5 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hwdep              16384  1 snd_hda_codec
snd_seq                69632  0
joydev                 20480  0
snd_seq_device         16384  1 snd_seq
edac_core              53248  0
snd_pcm               114688  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
edac_mce_amd           24576  0
k10temp                16384  0
snd_timer              32768  2 snd_pcm,snd_seq
shpchp                 36864  0
snd                    77824  24 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_via,snd_pcm,snd_seq,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
parport_pc             28672  0
soundcore              16384  1 snd
tpm_infineon           20480  0
parport                49152  2 ppdev,parport_pc
tpm_tis                20480  0
tpm                    36864  2 tpm_tis,tpm_infineon
asus_atk0110           20480  0
i2c_nforce2            16384  0
acpi_cpufreq           20480  0
nfsd                  315392  1
auth_rpcgss            61440  1 nfsd
nfs_acl                16384  1 nfsd
lockd                  94208  1 nfsd
grace                  16384  2 nfsd,lockd
sunrpc                311296  7 nfsd,auth_rpcgss,lockd,nfs_acl
ums_realtek            20480  0
uas                    24576  0
usb_storage            65536  2 uas,ums_realtek
ata_generic            16384  0
pata_acpi              16384  0
nouveau              1388544  7
i2c_algo_bit           16384  1 nouveau
drm_kms_helper        118784  1 nouveau
ttm                    90112  1 nouveau
mxm_wmi                16384  1 nouveau
drm                   335872  10 ttm,drm_kms_helper,nouveau
forcedeth              69632  0
serio_raw              16384  0
pata_amd               20480  0
video                  36864  1 nouveau
wmi                    20480  2 mxm_wmi,nouveau
bash-4.3$
Comment 2 John Duchek 2015-10-11 09:53:57 EDT
I have the same problem with the same error message.
Comment 3 Matthew Sainsbury 2015-11-05 05:54:50 EST
This seems to be a problem with avr-gcc. I tried to run avr-gcc on a non-arduino project and got the same error.

Invocation:

avr-gcc -v -O3 -ffunction-sections -fdata-sections -fpack-struct -Wall -std=gnu99 -s -mmcu=atmega48p main.c -o main.elf

I added the verbose flag to assist identifying a fix. See avrgcc-out.txt for an output listing
Comment 4 Matthew Sainsbury 2015-11-05 05:56 EST
Created attachment 1090017 [details]
Verbose Output of avr-gcc

This seems to be a problem with avr-gcc. I tried to run avr-gcc on a non-arduino project and got the same error.

Invocation:

avr-gcc -v -O3 -ffunction-sections -fdata-sections -fpack-struct -Wall -std=gnu99 -s -mmcu=atmega48p main.c -o main.elf

I added the verbose flag to assist identifying a fix. See avrgcc-out.txt for an output listing
Comment 5 cverhoef 2015-11-08 02:26:23 EST
Same issue here. As a workaround I downloaded the IDE 1.6.6. This works fine and I can compile my sketches again.
Comment 6 miguel rodriguez 2015-11-09 16:21:30 EST
I downloaded version 1.6 from Arduino page and unzipped the file. Run from the console the Arduino file and working properly. But that's because he already has in all libraries.
Comment 7 Fedora Admin XMLRPC Client 2015-11-19 16:00:19 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Fedora Admin XMLRPC Client 2015-11-23 13:01:10 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Dennis Chen 2015-11-24 14:36:18 EST
I am currently working on releasing the 1.6.6 version to the Fedora Rawhide, however, as mentioned by the previous maintainer, there is are many new libraries that must be released into Fedora stable before this upgrade can take place. 

It seems that avr-gcc version 5 is not building elfs properly. Until fixed by upstream, a method that may work is to downgrade to the latest version 4 provided by koji or copr. 

See BZ# 1182485, 1227491, 1245253
Comment 10 Dennis Chen 2015-12-04 16:10:17 EST
*** Bug 1288630 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.