Bug 1259668 - <AutomationEngine> MiqAeServiceModelBase.ar_method raised: <MiqException::MiqOrchestrationProvisionError>: <expected string value for option stack_name> on service provisioning of type "Orchestration"
<AutomationEngine> MiqAeServiceModelBase.ar_method raised: <MiqException::Miq...
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.4.0
Unspecified Unspecified
unspecified Severity medium
: GA
: 5.5.0
Assigned To: Bill Wei
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 06:20 EDT by Aziza Karol
Modified: 2015-11-11 15:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 12:35:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aziza Karol 2015-09-03 06:20:28 EDT
Created attachment 1069726 [details]
catalogitem

Description of problem:


Version-Release number of selected component (if applicable):
5.4.2

How reproducible:
100%

Steps to Reproduce:
1.From Automate customization create a service dialog.
2.create a catalog item of type  "Orchestration". see attached screenshot
2.From all service accordion, order the service.
3.check service->request details page.

Actual results:
request details page displays "expected string value for option stack_name (MiqException::MiqOrchestrationProvisionError)". see attached screenshot

Expected results:


Additional info:
evm.log
task_id([service_template_provision_task_7]) <AutomationEngine> Invoking [inline] method [/ManageIQ/Cloud/Orchestration/Provisioning/StateMachines/Methods/provision] with inputs [{}]
[----] I, [2015-09-03T01:00:31.710769 #13433:41dea8]  INFO -- : Q-task_id([service_template_provision_task_7]) <AutomationEngine> <AEMethod [/ManageIQ/Cloud/Orchestration/Provisioning/StateMachines/Methods/provision]> Starting 
[----] I, [2015-09-03T01:00:31.915414 #29403:825e9c]  INFO -- : MIQ(Vm-classify_with_parent_folder_path) Classifying VM: [s_tpl_downstream-54z_150506_RDKowhCz] with Category: [folder_path_yellow => Parent Folder Path (Hosts & Clusters)], Entry: [datacenters => Datacenters]
[----] I, [2015-09-03T01:00:31.953205 #29403:825e9c]  INFO -- : MIQ(Event.raise_evm_event): Event Raised [assigned_company_tag]
[----] I, [2015-09-03T01:00:31.976943 #29403:825e9c]  INFO -- : MIQ(Event.raise_evm_event): Alert for Event [assigned_company_tag]
[----] I, [2015-09-03T01:00:31.977168 #29403:825e9c]  INFO -- : MIQ(MiqAlert.evaluate_alerts) [assigned_company_tag] Target: TemplateVmware Name: [s_tpl_downstream-54z_150506_RDKowhCz], Id: [903]
[----] I, [2015-09-03T01:00:31.977689 #29403:825e9c]  INFO -- : MIQ(MiqQueue.delivered)  Message id: [95671], State: [ok], Delivered in [0.419228378] seconds
[----] I, [2015-09-03T01:00:32.025222 #29403:825e9c]  INFO -- : MIQ(MiqQueue.get_via_drb) Message id: [95672], MiqWorker id: [187], Zone: [default], Role: [], Server: [], Ident: [generic], Target id: [], Instance id: [831], Task id: [], Command: [TemplateVmware.classify_with_parent_folder_path], Timeout: [600], Priority: [200], State: [dequeue], Deliver On: [], Data: [], Args: [true], Dequeued in: [50.067400825] seconds
[----] I, [2015-09-03T01:00:32.025365 #29403:825e9c]  INFO -- : MIQ(MiqQueue.deliver)    Message id: [95672], Delivering...
[----] I, [2015-09-03T01:00:32.040853 #13433:614985c]  INFO -- : Q-task_id([service_template_provision_task_7]) <AutomationEngine> <AEMethod provision> Starting Orchestration Provisioning
[----] I, [2015-09-03T01:00:32.045383 #29403:825e9c]  INFO -- : MIQ(Vm-classify_with_parent_folder_path) Classifying VM: [s_tpl_downstream-54z_150511_lmyBk4I3] with Category: [folder_path_blue => Parent Folder Path (VMs & Templates)], Entry: [datacenters:cfme:vm => Datacenters/CFME/vm]
[----] I, [2015-09-03T01:00:32.111571 #29403:825e9c]  INFO -- : MIQ(Event.raise_evm_event): Event Raised [assigned_company_tag]
[----] I, [2015-09-03T01:00:32.134874 #29403:825e9c]  INFO -- : MIQ(Event.raise_evm_event): Alert for Event [assigned_company_tag]
[----] I, [2015-09-03T01:00:32.135066 #29403:825e9c]  INFO -- : MIQ(MiqAlert.evaluate_alerts) [assigned_company_tag] Target: TemplateVmware Name: [s_tpl_downstream-54z_150511_lmyBk4I3], Id: [831]
[----] E, [2015-09-03T01:00:32.141074 #13433:614985c] ERROR -- : Q-task_id([service_template_provision_task_7]) MIQ(EmsAmazon#stack_create) stack=[], error: expected string value for option stack_name
[----] I, [2015-09-03T01:00:32.162379 #29403:825e9c]  INFO -- : MIQ(Vm-classify_with_parent_folder_path) Classifying VM: [s_tpl_downstream-54z_150511_lmyBk4I3] with Category: [folder_path_yellow => Parent Folder Path (Hosts & Clusters)], Entry: [datacenters => Datacenters]
[----] E, [2015-09-03T01:00:32.200480 #13433:614985c] ERROR -- : Q-task_id([service_template_provision_task_7]) <AutomationEngine> The following error occurred during instance method <deploy_orchestration_stack> for AR object <#<ServiceOrchestration id: 1, name: "item1", description: "item1", guid: "adf763fc-51f8-11e5-a3e9-fa163e1df7e4", type: "ServiceOrchestration", service_template_id: 1, options: {:dialog=>{"dialog_ele"=>"aziza"}, :stack_name=>nil, :stack_ems_ref=>nil, :create_options=>{:parameters=>{}, :disable_rollback=>true}}, display: true, created_at: "2015-09-03 05:00:21", updated_at: "2015-09-03 05:00:32", evm_owner_id: 1, miq_group_id: 1, service_id: nil, retired: nil, retires_on: nil, retirement_warn: nil, retirement_last_warn: nil, retirement_state: nil, retirement_requester: nil>>
[----] E, [2015-09-03T01:00:32.200693 #13433:614985c] ERROR -- : Q-task_id([service_template_provision_task_7]) <AutomationEngine> MiqAeServiceModelBase.ar_method raised: <MiqException::MiqOrchestrationProvisionError>: <expected string value for option stack_name>
[----] E, [2015-09-03T01:00:32.200834 #13433:614985c] ERROR -- : Q-task_id([service_template_provision_task_7]) <AutomationEngine> /opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/option_grammar.rb:93:in `validate'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/option_grammar.rb:590:in `block in validate'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/option_grammar.rb:586:in `each'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/option_grammar.rb:586:in `validate'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/option_grammar.rb:601:in `request_params'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/query_request_builder.rb:37:in `populate_request'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/client.rb:740:in `block (2 levels) in define_client_method'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/client.rb:560:in `build_request'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/client.rb:491:in `block (3 levels) in client_request'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/response.rb:175:in `call'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/response.rb:175:in `build_request'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/response.rb:114:in `initialize'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/client.rb:203:in `new'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/client.rb:203:in `new_response'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/client.rb:490:in `block (2 levels) in client_request'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/client.rb:391:in `log_client_request'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/client.rb:477:in `block in client_request'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/client.rb:373:in `return_or_raise'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/core/client.rb:476:in `client_request'
(eval):3:in `create_stack'
/opt/rh/cfme-gemset/gems/aws-sdk-v1-1.56.0/lib/aws/cloud_formation/stack_collection.rb:146:in `create'
/var/www/miq/vmdb/app/models/ems_amazon.rb:129:in `stack_create'
/var/www/miq/vmdb/app/models/service_orchestration.rb:29:in `deploy_orchestration_stack'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:239:in `block in object_send'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:259:in `ar_method'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:270:in `ar_method'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:237:in `object_send'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:92:in `block (2 levels) in expose'
/opt/rh/ruby200/root/usr/share/ruby/drb/drb.rb:1588:in `perform_without_block'
/opt/rh/ruby200/root/usr/share/ruby/drb/drb.rb:1548:in `perform'
/opt/rh/ruby200/root/usr/share/ruby/drb/drb.rb:1626:in `block (2 levels) in main_loop'
/opt/rh/ruby200/root/usr/share/ruby/drb/drb.rb:1622:in `loop'
/opt/rh/ruby200/root/usr/share/ruby/drb/drb.rb:1622:in `block in main_loop'
/var/www/miq/vmdb/lib/extensions/ar_thread.rb:22:in `block in start_with_release'
[----] I, [2015-09-03T01:00:32.252873 #29403:825e9c]  INFO -- : MIQ(Event.raise_evm_event): Event Raised [assigned_company_tag]
[----] I, [2015-09-03T01:00:32.275386 #29403:825e9c]  INFO -- : MIQ(Event.raise_evm_event): Alert for Event [assigned_company_tag]
[----] I, [2015-09-03T01:00:32.275559 #29403:825e9c]  INFO -- : MIQ(MiqAlert.evaluate_alerts) [assigned_company_tag] Target: TemplateVmware Name: [s_tpl_downstream-54z_150511_lmyBk4I3], Id: [831]
[----] I, [2015-09-03T01:00:32.276208 #29403:825e9c]  INFO -- : MIQ(MiqQueue.delivered)  Message id: [95672], State: [ok], Delivered in [0.250838503] seconds
[----] E, [2015-09-03T01:00:32.417617 #13433:6339e8c] ERROR -- : Q-task_id([service_template_provision_task_7]) <AutomationEngine> <AEMethod provision> Stack  creation failed. Reason: expected string value for option stack_name (MiqException::MiqOrchestrationProvisionError)
Comment 3 Dave Johnson 2015-09-03 12:35:12 EDT
We spoke about this one on the bug triage call, believe this is working as designed, and caused by not creating the dialog from the stack template.  

Aziza, can you please work with Bill to determine the proper sequence of steps that you need to follow.

Note You need to log in before you can comment on or make changes to this bug.