Bug 1259703 - Totem is segfaulting
Totem is segfaulting
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mesa (Show other bugs)
7.2
s390x Linux
unspecified Severity high
: beta
: ---
Assigned To: Dave Airlie
Desktop QE
:
Depends On:
Blocks: 1295396
  Show dependency treegraph
 
Reported: 2015-09-03 08:02 EDT by Ladislav Kolacek
Modified: 2017-08-08 10:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 02:50:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (40.29 KB, text/plain)
2015-09-03 08:02 EDT, Ladislav Kolacek
no flags Details
backtrace2 (40.91 KB, text/plain)
2016-01-14 07:44 EST, Ladislav Kolacek
no flags Details

  None (edit)
Description Ladislav Kolacek 2015-09-03 08:02:30 EDT
Created attachment 1069770 [details]
backtrace

Description of problem:

Totem is segfaulting sometimes when you play video/audio file and sometimes when you simply run totem. 

Version-Release number of selected component (if applicable):
totem-3.14.3-2.el7.s390x
kernel-3.10.0-308.el7.s390x

How reproducible:
80%

Actual results:
Segmentation fault (more information is in attachment)

Expected results:
Totem should be successfully run and be able to play audio/video files.

Additional info:
This problem appears only on architecture s390x.
Comment 1 Bastien Nocera 2015-09-03 12:16:09 EDT
Can you generate a backtrace with gdb? So I know in which thread it's actually crashing.

How are you testing this on s390? Are you using a remote display? Is the X server you're running this on OpenGL-capable?

A word of warning, this is most likely a problem deeper down in GStreamer though.
Comment 2 Ladislav Kolacek 2015-09-04 06:24:18 EDT
Backtrace in attachment was created by gdb.

I tested arch s390x by x11vnc and Remote Desktop Viewer like the other architectures where application worked fine. 

Should I switch component to gstreamer?
Comment 3 Bastien Nocera 2016-01-12 12:03:41 EST
(In reply to Ladislav Kolacek from comment #2)
> Backtrace in attachment was created by gdb.

But you're missing the bit before the backtrace where it says where and why it crashed (which signal, and in which thread).

I can't figure that from the backtrace you posted.

> I tested arch s390x by x11vnc and Remote Desktop Viewer like the other
> architectures where application worked fine. 
> 
> Should I switch component to gstreamer?

Not yet.
Comment 4 Ladislav Kolacek 2016-01-14 07:44 EST
Created attachment 1114793 [details]
backtrace2

Adding complete backtrace from gdb.
Comment 5 Bastien Nocera 2016-05-18 09:35:54 EDT
I can't do anything with the backtrace. The thread that crashes has no data:

> Program received signal SIGSEGV, Segmentation fault.
> [Switching to Thread 0x3ffee65d910 (LWP 44266)]
> 0x000003ffe67f804e in ?? ()
> 
> Thread 4 (Thread 0x3ffee65d910 (LWP 44266)):
> #0  0x000003ffe67f804e in ?? ()
> No symbol table info available.

Does using gst-play-1.0 work on that same file? Can you try running valgrind on the application (if valgrind is available in s390)?
Comment 6 Ladislav Kolacek 2016-05-19 08:58 EDT
Created attachment 1159471 [details]
valgrind

I tested this bug on current version of RHEL 7.3 and I was not able to reproduce problem with segfaulting. Totem no longer crashes and video is playable now. 

However, I also tested totem via valgrind and it returns large amount of Errors. Totem was killed in the end. (output is in attachment)

Tool gst-play-1.0 is not installed on VM.

Adding version of components:
totem-3.14.3-5.el7.s390x
kernel-3.10.0-401.el7.s390x
gstreamer-plugins-bad-free-0.10.23-20.el7.s390x
Comment 8 Bastien Nocera 2016-05-19 09:18:59 EDT
(In reply to Ladislav Kolacek from comment #6)
> Created attachment 1159471 [details]
> valgrind
> 
> I tested this bug on current version of RHEL 7.3 and I was not able to
> reproduce problem with segfaulting. Totem no longer crashes and video is
> playable now. 
> 
> However, I also tested totem via valgrind and it returns large amount of
> Errors. Totem was killed in the end. (output is in attachment)

Not sure why you used "--leak-check=full", as we're not checking for leaks.

Looks to me that the problem is likely to be in the LLVM software renderer in Mesa.

> Tool gst-play-1.0 is not installed on VM.

Then install it? I'm guessing that you might not be able to reproduce the bug though, as this won't use OpenGL.
Comment 9 Tomas Pelka 2016-05-19 15:29:48 EDT
(In reply to Bastien Nocera from comment #8)
> (In reply to Ladislav Kolacek from comment #6)
> > Created attachment 1159471 [details]
> > valgrind
> > 
> > I tested this bug on current version of RHEL 7.3 and I was not able to
> > reproduce problem with segfaulting. Totem no longer crashes and video is
> > playable now. 
> > 
> > However, I also tested totem via valgrind and it returns large amount of
> > Errors. Totem was killed in the end. (output is in attachment)
> 
> Not sure why you used "--leak-check=full", as we're not checking for leaks.
> 
> Looks to me that the problem is likely to be in the LLVM software renderer
> in Mesa.
> 
> > Tool gst-play-1.0 is not installed on VM.
> 
> Then install it? I'm guessing that you might not be able to reproduce the
> bug though, as this won't use OpenGL.

Lado it should be part of gstreamer1-plugins-base.
Comment 10 Dave Airlie 2017-07-27 20:49:02 EDT
please retest with RHEL7.4 to see if this has changed.
Comment 11 Tomas Hudziec 2017-07-31 12:23:16 EDT
In RHEL7.4 totem is not segfaulting. It is able to play video/audio files.
Only when run via command line without input file, following message is shown for each video:
(totem:38815): Grilo-CRITICAL **: grl_source_resolve: assertion 'GRL_IS_SOURCE (source)' failed
versions of components:
totem-3.22.1-1.el7.s390x
kernel-3.10.0-693.el7.s390x
Comment 12 Tomas Pelka 2017-08-01 02:50:38 EDT
(In reply to Tomas Hudziec from comment #11)
> In RHEL7.4 totem is not segfaulting. It is able to play video/audio files.
> Only when run via command line without input file, following message is
> shown for each video:
> (totem:38815): Grilo-CRITICAL **: grl_source_resolve: assertion
> 'GRL_IS_SOURCE (source)' failed
> versions of components:
> totem-3.22.1-1.el7.s390x
> kernel-3.10.0-693.el7.s390x

I would advice to file another bug against grilo.
Comment 13 Tomas Hudziec 2017-08-01 06:00:07 EDT
(In reply to Tomas Pelka from comment #12)

> I would advice to file another bug against grilo.

Filed: https://bugzilla.redhat.com/show_bug.cgi?id=1477129
Comment 14 Tomas Hudziec 2017-08-08 10:29:15 EDT
(In reply to Tomas Pelka from comment #9)
> (In reply to Bastien Nocera from comment #8)
> > (In reply to Ladislav Kolacek from comment #6)
> > > Created attachment 1159471 [details]
> > > valgrind
> > > 
> > > I tested this bug on current version of RHEL 7.3 and I was not able to
> > > reproduce problem with segfaulting. Totem no longer crashes and video is
> > > playable now. 
> > > 
> > > However, I also tested totem via valgrind and it returns large amount of
> > > Errors. Totem was killed in the end. (output is in attachment)
> > 
> > Not sure why you used "--leak-check=full", as we're not checking for leaks.
> > 
> > Looks to me that the problem is likely to be in the LLVM software renderer
> > in Mesa.
> > 
> > > Tool gst-play-1.0 is not installed on VM.
> > 
> > Then install it? I'm guessing that you might not be able to reproduce the
> > bug though, as this won't use OpenGL.
> 
> Lado it should be part of gstreamer1-plugins-base.

gst-play-1.0 is part of gstreamer1-plugins-base-tools.

Note You need to log in before you can comment on or make changes to this bug.