Bug 1259769 - Flick publish gives 403 after authentication
Flick publish gives 403 after authentication
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: shotwell (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Debarshi Ray
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 09:56 EDT by Vadim Rutkovsky
Modified: 2017-09-25 05:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-25 05:00:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 732432 None None None 2016-09-19 11:22 EDT

  None (edit)
Description Vadim Rutkovsky 2015-09-03 09:56:22 EDT
Description of problem:
Flick publish cannot be completed:

Version-Release number of selected component (if applicable):
shotwell-0.14.1-5.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Add Flickr account in Gnome Online Accounts (see https://wiki.test.redhat.com/Desktop/OnlineAccounts#Yahoo)
2. Select a photo in Shotwell and click 'Publish'
3. Select 'Flickr' and enter the authorisation code

Actual results:

'Service http://api.flickr.com/services/rest returned HTTP status code 403: Forbidden'

Expected results:
Photo is published

Additional info:
Comment 1 Debarshi Ray 2016-09-19 11:22:52 EDT
I suspect that backporting this commit should fix this:

commit ead3a6f75c001059980cc4a2c287feb0622f3c89
Author: Joseph Bylund <joseph.bylund@gmail.com>
Date:   Mon Jun 30 13:53:20 2014 -0700

    Fix Flickr publishing (now HTTPs only): Bug #732432
Comment 2 Debarshi Ray 2017-09-23 09:52:58 EDT
Shotwell was rebased to 0.24.5 (bug 1387046). I suspect that the rebase might have fixed this. Could you confirm?
Comment 3 Tomas Pelka 2017-09-25 02:57:03 EDT
Michale please check with latest shotwell and close if this is already fixed.

Thanks
-Tom
Comment 4 Michal Odehnal 2017-09-25 05:00:52 EDT
Closing this bug, I was not able to reproduce this problem with shotwell-0.24.5-1.el7.x86_64.

Note You need to log in before you can comment on or make changes to this bug.