Bug 1259774 - [abrt] plasma-workspace: KCrash::defaultCrashHandler(int)(): plasmashell killed by SIGSEGV
[abrt] plasma-workspace: KCrash::defaultCrashHandler(int)(): plasmashell kill...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: plasma-workspace (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: KDE SIG
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:4bd37b49d1a031b15841898b97f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 10:01 EDT by Jakub Filak
Modified: 2016-11-30 19:49 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-21 13:57:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (57.65 KB, text/plain)
2015-09-03 10:01 EDT, Jakub Filak
no flags Details
File: cgroup (289 bytes, text/plain)
2015-09-03 10:01 EDT, Jakub Filak
no flags Details
File: core_backtrace (8.46 KB, text/plain)
2015-09-03 10:01 EDT, Jakub Filak
no flags Details
File: dso_list (15.79 KB, text/plain)
2015-09-03 10:01 EDT, Jakub Filak
no flags Details
File: environ (1.65 KB, text/plain)
2015-09-03 10:01 EDT, Jakub Filak
no flags Details
File: limits (1.29 KB, text/plain)
2015-09-03 10:01 EDT, Jakub Filak
no flags Details
File: maps (69.17 KB, text/plain)
2015-09-03 10:01 EDT, Jakub Filak
no flags Details
File: mountinfo (3.42 KB, text/plain)
2015-09-03 10:01 EDT, Jakub Filak
no flags Details
File: namespaces (85 bytes, text/plain)
2015-09-03 10:01 EDT, Jakub Filak
no flags Details
File: open_fds (191 bytes, text/plain)
2015-09-03 10:01 EDT, Jakub Filak
no flags Details
File: proc_pid_status (1021 bytes, text/plain)
2015-09-03 10:01 EDT, Jakub Filak
no flags Details
File: var_log_messages (719 bytes, text/plain)
2015-09-03 10:01 EDT, Jakub Filak
no flags Details

  None (edit)
Description Jakub Filak 2015-09-03 10:01:31 EDT
Description of problem:
When I try to log in to Plasma, the progress bar reaches the end and yakuake is successfully started but the workspace does not appear. The crash appeared 6 days ago, I update my at trhee times since the crashe appeared and I reproduced it several times, so the crash is unlikely an update issue.

Version-Release number of selected component:
plasma-workspace-5.4.0-2.fc24

Additional info:
reporter:       libreport-2.6.2.5.g85e6.dirty
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell -s --crashes 1
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     30963
kernel:         4.2.0-0.rc8.git1.1.fc24.x86_64
runlevel:       N 5
type:           CCpp
uid:            18601

Truncated backtrace:
Thread no. 1 (1 frames)
 #1 KCrash::defaultCrashHandler(int) at ../../src/kcrash.cpp:409

Potential duplicate: bug 1259472
Comment 1 Jakub Filak 2015-09-03 10:01:35 EDT
Created attachment 1069860 [details]
File: backtrace
Comment 2 Jakub Filak 2015-09-03 10:01:36 EDT
Created attachment 1069861 [details]
File: cgroup
Comment 3 Jakub Filak 2015-09-03 10:01:38 EDT
Created attachment 1069862 [details]
File: core_backtrace
Comment 4 Jakub Filak 2015-09-03 10:01:39 EDT
Created attachment 1069863 [details]
File: dso_list
Comment 5 Jakub Filak 2015-09-03 10:01:42 EDT
Created attachment 1069864 [details]
File: environ
Comment 6 Jakub Filak 2015-09-03 10:01:43 EDT
Created attachment 1069865 [details]
File: limits
Comment 7 Jakub Filak 2015-09-03 10:01:45 EDT
Created attachment 1069866 [details]
File: maps
Comment 8 Jakub Filak 2015-09-03 10:01:46 EDT
Created attachment 1069867 [details]
File: mountinfo
Comment 9 Jakub Filak 2015-09-03 10:01:48 EDT
Created attachment 1069868 [details]
File: namespaces
Comment 10 Jakub Filak 2015-09-03 10:01:49 EDT
Created attachment 1069869 [details]
File: open_fds
Comment 11 Jakub Filak 2015-09-03 10:01:50 EDT
Created attachment 1069870 [details]
File: proc_pid_status
Comment 12 Jakub Filak 2015-09-03 10:01:51 EDT
Created attachment 1069871 [details]
File: var_log_messages
Comment 13 Jakub Filak 2015-09-21 04:38:28 EDT
I have just upgraded my box to plasma-workspace-5.4.1-4.fc24 and I still cannot log in to my Desktop successfully. If I wait around a minute, the progress bar disappears and I can use Alt+F2. I tried to run konsole but it crashes (I can run konsole when I am logged in to gnome-shell :).

I removed $HOME/.kde but it didn't help. What else I can remove?

New FAF (ABRT server) report:
https://retrace.fedoraproject.org/faf/reports/814077/

$ gdb -c coredump:

#3  0x00007fa58d83f410 in __strncpy_sse2_unaligned () at /lib64/libc.so.6
#4  0x00007fa591eff789 in NETRootInfo::update(QFlags<NET::Property>, QFlags<NET::Property2>) () at /lib64/libKF5WindowSystem.so.5
#5  0x00007fa56f1d9e94 in KWindowSystemPrivateX11::init(KWindowSystemPrivateX11::FilterInfo) () at /usr/lib64/qt5/plugins/kf5/org.kde.kwindowsystem.platforms/KF5WindowSystemX11Plugin.so
#6  0x00007fa56f1da066 in KWindowSystemPrivateX11::connectNotify(QMetaMethod const&) () at /usr/lib64/qt5/plugins/kf5/org.kde.kwindowsystem.platforms/KF5WindowSystemX11Plugin.so
#7  0x00007fa591eede18 in KWindowSystem::connectNotify(QMetaMethod const&) () at /lib64/libKF5WindowSystem.so.5
#8  0x00007fa58e6b464a in QObjectPrivate::connectImpl(QObject const*, int, QObject const*, void**, QtPrivate::QSlotObjectBase*, Qt::ConnectionType, int const*, QMetaObject const*) ()
    at /lib64/libQt5Core.so.5
#9  0x00007fa58e6b480a in QObject::connectImpl(QObject const*, void**, QObject const*, void**, QtPrivate::QSlotObjectBase*, Qt::ConnectionType, int const*, QMetaObject const*) ()
    at /lib64/libQt5Core.so.5
#10 0x000055c869f13d29 in ShellCorona::ShellCorona(QObject*) (type=Qt::DirectConnection, slot=..., context=0x7fa5921170a0, signal=
    (void (KWindowSystem::*)(KWindowSystem * const, bool)) 0x7fa591f07960 <KWindowSystem::showingDesktopChanged(bool)>, sender=0x7fa5921170a0) at /usr/include/qt5/QtCore/qobject.h:349
#11 0x000055c869f13d29 in ShellCorona::ShellCorona(QObject*) (slot=..., signal=<optimized out>, sender=0x7fa5921170a0) at /usr/include/qt5/QtCore/qobject.h:287
#12 0x000055c869f13d29 in ShellCorona::ShellCorona(QObject*) (this=0x55c86b7df8f0, parent=<optimized out>) at ../../shell/shellcorona.cpp:154
#13 0x000055c869f1d45c in ShellManager::loadHandlers() (this=0x55c86b7d91a0) at ../../shell/shellmanager.cpp:103
#14 0x00007fa58e6b2021 in QObject::event(QEvent*) () at /lib64/libQt5Core.so.5
#15 0x00007fa58fc384ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#16 0x00007fa58fc3d976 in QApplication::notify(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#17 0x00007fa58e68261b in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /lib64/libQt5Core.so.5
#18 0x00007fa58e684a16 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /lib64/libQt5Core.so.5
#19 0x00007fa58e6d8983 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () at /lib64/libQt5Core.so.5
#20 0x00007fa5889ccf0a in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#21 0x00007fa5889cd2a0 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#22 0x00007fa5889cd34c in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#23 0x00007fa58e6d8d8f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#24 0x00007fa58e67fdaa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#25 0x00007fa58e687e6c in QCoreApplication::exec() () at /lib64/libQt5Core.so.5
#26 0x000055c869eec363 in main(int, char**) (argc=4, argv=<optimized out>) at ../../shell/main.cpp:176
Comment 14 Rex Dieter 2015-09-21 08:48:15 EDT
~/.kde/ isn't used by plasma5, rather (xdg standard) ~/.config and ~/.local/share
Comment 15 Jakub Filak 2015-09-21 13:57:50 EDT
Thank you! I removed plenty of files from those directories and I have destroyed my profile completely, though, I am happy because plasmashell has stopped crashing. 

I am closing as NOTABUGT, even though one might consider this behavior as buggy.

Note You need to log in before you can comment on or make changes to this bug.