Bug 1259775 - Evince dies on app exit
Evince dies on app exit
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 10:02 EDT by Zdenek Kabelac
Modified: 2017-01-16 06:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-16 06:35:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2015-09-03 10:02:32 EDT
Description of problem:

When I clicked 'cross' button to close the app - Evince has died:

#0  g_type_check_instance_cast (type_instance=type_instance@entry=0x5584f29300e0, iface_type=94029491237936) at gtype.c:4060

4060		  node = lookup_type_node_I (type_instance->g_class->g_type);
#1  0x00007f7bd6257e47 in send_delete_event (data=0x5584f29300e0) at gtkwindow.c:1314
#2  0x00007f7bd5bf8408 in gdk_threads_dispatch (data=0x7f7bbc02bea0) at gdk.c:719
#3  0x00007f7bd452ee9a in g_main_context_dispatch (context=0x5584f26ee7c0) at gmain.c:3154
#4  0x00007f7bd452ee9a in g_main_context_dispatch (context=context@entry=0x5584f26ee7c0) at gmain.c:3769
#5  0x00007f7bd452f230 in g_main_context_iterate (context=context@entry=0x5584f26ee7c0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>)
    at gmain.c:3840
#6  0x00007f7bd452f2dc in g_main_context_iteration (context=0x5584f26ee7c0, context@entry=0x0, may_block=may_block@entry=1) at gmain.c:3901
#7  0x00007f7bd4b21c1c in g_application_run (application=0x5584f28b7130 [EvApplication], argc=0, argv=0x0) at gapplication.c:2311
#8  0x00005584f0c261e7 in main (argc=1, argv=0x7ffc11a995c8) at main.c:316

(gdb) print type_instance
$1 = 0x5584f29300e0
(gdb) print type_instance->g_class
$2 = (GTypeClass *) 0xaaaaaaaaaaaaaaaa


Clearly g_class is already garbage - so some closing order issue ?
Possibly it could be  gtk3 bug - so feel free to forward in that case.


Version-Release number of selected component (if applicable):
evince-3.17.4-1.fc24.x86_64


How reproducible:


Steps to Reproduce:
1. close app with 'cross' button
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jan Kurik 2016-02-24 08:42:41 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Fedora Admin XMLRPC Client 2016-10-14 04:09:49 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Caolan McNamara 2017-01-16 06:35:50 EST
seems to be good in final release. I don't see it in Fedora 25 anyway and no memory of failure in Fedora 24

Note You need to log in before you can comment on or make changes to this bug.