Bug 1259835 - libpsm2 library conflict with infinipath-psm
libpsm2 library conflict with infinipath-psm
Status: CLOSED DUPLICATE of bug 1273155
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libpsm2 (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.3
Assigned To: Michal Schmidt
yanfu,wang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 11:15 EDT by Michal Schmidt
Modified: 2016-08-05 10:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-05 10:11:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
small reproducer program (1.03 KB, application/x-gzip)
2015-09-03 11:16 EDT, Michal Schmidt
no flags Details

  None (edit)
Description Michal Schmidt 2015-09-03 11:15:56 EDT
Description of problem:
libpsm_infinipath.so.1 from infinipath-psm provides the PSM API to use TrueScale devices.
libpsm2.so.2 from libpsm2 provides the PSM2 API to use OmniPath devices.

The two APIs clash with each other when a process links to both libraries.
For instance, both libraries provide a function called "psm_init".

Version-Release number of selected component (if applicable):
libpsm2-0.7-3.el7.x86_64
infinipath-psm-3.3-0.g6f42cdb1bb8.2.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. tar -xvf test-psm-conflict.tar.gz && cd test-psm-conflict && make
2. ./test

Actual results:
./plugin0.so initialized
PSM loaded an unexpected/unsupported version (2.0)
./plugin1.so initialization failed


Expected results:
./plugin0.so initialized
./plugin1.so initialized

(The expected result would appear if the implemented solution unified the two libraries into one, usable for both TrueScale and OmniPath.
A different solution may be an new non-conflicting API for PSM2, in which case the test program would need changes to work.)

Additional info:
This affects openmpi. A workaround has been put in place in openmpi to avoid loading both PSM libraries at the same time.
I will reference this BZ from openmpi's config file with the workaround, so I do not wish to mark the BZ private.
Comment 1 Michal Schmidt 2015-09-03 11:16:48 EDT
Created attachment 1069924 [details]
small reproducer program
Comment 2 Michal Schmidt 2016-08-05 10:11:51 EDT
The conflict is resolved in libpsm2 by changing the function names from psm_* to psm2_*.

*** This bug has been marked as a duplicate of bug 1273155 ***

Note You need to log in before you can comment on or make changes to this bug.