This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 125999 - spamassassin-2.63-krb5-backcompat.patch won't apply
spamassassin-2.63-krb5-backcompat.patch won't apply
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-14 21:11 EDT by Kenneth Porter
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-12 08:29:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Replacement patch (711 bytes, patch)
2004-06-14 21:24 EDT, Kenneth Porter
no flags Details | Diff
replacement spamassassin-3.0-krb5-backcompat.patch (717 bytes, patch)
2004-09-11 23:59 EDT, John Lundin
no flags Details | Diff

  None (edit)
Description Kenneth Porter 2004-06-14 21:11:37 EDT
This patch gets pulled in when building on Red Hat 8, and doesn't
apply to Makefile.PL. This might be a side effect of splitting spamc
into its own subdirectory. I'm guessing an updated patch should be
modifying line 1033.
Comment 1 Kenneth Porter 2004-06-14 21:24:43 EDT
Created attachment 101131 [details]
Replacement patch

I don't see any changes to the spamc directory when this is applied, so I don't
know that it's the correct solution, but it allows the package to build.
Comment 2 Warren Togami 2004-06-14 21:37:45 EDT
Thank you.  I will add this to the rawhide SRPM when I upgrade to the
official pre-release coming within the next few days.
Comment 3 Warren Togami 2004-06-20 23:15:30 EDT
applied to the next rawhide package.  Please CLOSE this report as
RAWHIDE after you verify that it works.  3.0-2.pre1 or later.
Comment 4 Kenneth Porter 2004-07-12 17:42:34 EDT
The package builds on both FC2 (no krb5) and RH8 (with krb5).

Attempting to build and install the package on RH8 with a prior RPM
set from the SA site installed results in a dependency failure on
spamassassin-tools (provided by the SA site's SRPM). I erased the
-tools RPM and now get this failed dependency:

error: Failed dependencies:
        perl(:MODULE_COMPAT_5.8.0) is needed by spamassassin-3.0-2.pre1

If the Fedora RPM won't be providing a -tools subpackage, it should
obsolete the old upstream one.
Comment 5 Warren Togami 2004-07-12 23:42:27 EDT
Just erase that line.  It is not possible to make that compatible with
older versions of perl.  I am considering adding a Provides -tools,
but first I will analyze the upstream .spec to see if we can become
closer in compatibility.  Low priority to me.
Comment 6 John Lundin 2004-09-11 23:59:17 EDT
Created attachment 103752 [details]
replacement spamassassin-3.0-krb5-backcompat.patch

fd6b163accb3e7cabf90a6d49d7d346c133d1d6b 
spamassassin-3.0-krb5-backcompat.patch

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)
 
iD8DBQBBQ58BXnz+llbrkzARAszfAJ0e8oAtVKIj8eLIpUnf69cQLwe93QCdFZFS
R4WAxecAfVigQE1+JLihNe0=
=lA5w
-----END PGP SIGNATURE-----
Comment 7 John Lundin 2004-09-12 00:20:25 EDT
spamassassin-3.0-krb5-backcompat.patch in
spamassassin-3.0-7.rc2.src.rpm doesn't apply under RH8 either.

On the other hand, when I use this one instead (with that
MODULE_COMPAT line removed from the spec file), it works for me in RH8.

BTW, a trivial SArc4 variant SRPM builds and runs on RH8, FC1, FC2.

Comment 8 Warren Togami 2004-09-12 00:37:03 EDT
http://www.fedora.us/pkglists/8.0/stable/perl-forward-compat-5.8.0-0.fdr.2.src.rpm.html
MODULE_COMPAT requires perl-forward-compat on RH8 and RH9.  You can
install it from fedora.us Extras stable.
Comment 9 Warren Togami 2004-09-12 08:29:50 EDT
Thanks for the patch John.  It will be in rawhide after we unfreeze.

Note You need to log in before you can comment on or make changes to this bug.