Bug 1259991 - [Docs] [Director] Install guide shows "dhcp: true" in disabled network example
[Docs] [Director] Install guide shows "dhcp: true" in disabled network example
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: y1
: 7.0 (Kilo)
Assigned To: Dan Macpherson
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 01:23 EDT by jliberma@redhat.com
Modified: 2015-10-13 22:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 22:27:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jliberma@redhat.com 2015-09-04 01:23:25 EDT
Description of problem:

ml/Director_Installation_and_Usage/sect-Scenario_2_Using_the_CLI_to_Create_a_Basic_Overcloud.html#sect-Isolating_the_External_Network

The example for disabling an unused interface appears to be enabled:
- type: interface
  name: nic1
  use_dhcp: true

Should be:
- type: interface
  name: nic1
  use_dhcp: false

Please close as not a bug if I am wrong.
Comment 3 Mike Burns 2015-09-04 07:06:28 EDT
Adding dsneddon to confirm and moving to the documentation component
Comment 4 Dan Sneddon 2015-09-04 13:14:30 EDT
Jacob is correct, the docs should read "use_dhcp: false" for that stanza.
Comment 5 Andrew Dahms 2015-09-07 20:23:37 EDT
Assigning to Dan for review.
Comment 6 Dan Macpherson 2015-09-07 21:02:21 EDT
I think it might be poor wording on my behalf. What I was trying to say in that section was to remove sections for unused nics and using that segment of the network interface template as an example of what to remove. Whether dhcp is enabled or not doesn't really matter because the recommendation is to remove those sections. I'll try and reword this section to convey my meaning a bit better. I'll also include some info for just disabling dhcp too.
Comment 7 jliberma@redhat.com 2015-09-07 22:21:11 EDT
sounds good mate

i wasnt sure the example conveyed your intent
Comment 9 Dan Macpherson 2015-09-24 22:50:32 EDT
Hi Jacob,

I've updated the warning in the Basic and Advanced scenarios to the following:

== Important ==
Unused interfaces can cause unwanted default routes and network loops. For example, your template might contain a network interface (nic4) that does not use any IP assignments for OpenStack services but still uses DHCP and/or a default route. To avoid network conflicts, remove any used interfaces from ovs_bridge devices and disable the DHCP and default route settings:

- type: interface
  name: nic4
  use_dhcp: false
  defroute: false


(Example in Basic Scenario: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Scenario_2_Using_the_CLI_to_Create_a_Basic_Overcloud.html#sect-Isolating_the_External_Network)

What do you think? Does this clarify the message a little better?
Comment 10 jliberma@redhat.com 2015-10-12 10:59:36 EDT
That looks great, thanks Dan.

Note You need to log in before you can comment on or make changes to this bug.