Bug 1260010 - SELinux is preventing NetworkManager from 'create' accesses on the netlink_generic_socket Unknown.
SELinux is preventing NetworkManager from 'create' accesses on the netlink_ge...
Status: CLOSED DUPLICATE of bug 1259180
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:853b9802c618ebe9a66e73f6bcd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 03:30 EDT by Joachim Frieben
Modified: 2015-09-11 06:34 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-11 06:34:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2015-09-04 03:30:09 EDT
Description of problem:
SELinux is preventing NetworkManager from 'create' accesses on the netlink_generic_socket Unknown.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that NetworkManager should be allowed create access on the Unknown netlink_generic_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep NetworkManager /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:NetworkManager_t:s0
Target Context                system_u:system_r:NetworkManager_t:s0
Target Objects                Unknown [ netlink_generic_socket ]
Source                        NetworkManager
Source Path                   NetworkManager
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-146.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.0-1.fc23.x86_64 #1 SMP Mon Aug
                              31 15:57:27 UTC 2015 x86_64 x86_64
Alert Count                   2
First Seen                    2015-09-04 06:05:18 CEST
Last Seen                     2015-09-04 09:25:51 CEST
Local ID                      6dab0435-5efe-40c0-80de-c301044179bc

Raw Audit Messages
type=AVC msg=audit(1441351551.58:682): avc:  denied  { create } for  pid=27669 comm="NetworkManager" scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:system_r:NetworkManager_t:s0 tclass=netlink_generic_socket permissive=0


Hash: NetworkManager,NetworkManager_t,NetworkManager_t,netlink_generic_socket,create

Version-Release number of selected component:
selinux-policy-3.13.1-146.fc23.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.2.0-1.fc23.x86_64
type:           libreport

Potential duplicate: bug 1259180
Comment 1 Miroslav Grepl 2015-09-11 06:34:32 EDT

*** This bug has been marked as a duplicate of bug 1259180 ***

Note You need to log in before you can comment on or make changes to this bug.