Bug 1260059 - Please rebuild with NetworkManager 1.2 support for Fedora 24
Please rebuild with NetworkManager 1.2 support for Fedora 24
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager-l2tp (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ivan Romanov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 06:38 EDT by Lubomir Rintel
Modified: 2016-04-23 11:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-23 11:26:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Rintel 2015-09-04 06:38:55 EDT
Hi,

we've updated NetworkManager to 1.2 snapshot. Details:
https://lists.fedoraproject.org/pipermail/devel/2015-September/214016.html

NetworkManager-l2tp needs to be updated to work with the new nm-connection-editor. I've submitted the port upstream:

https://github.com/seriyps/NetworkManager-l2tp/pull/38

In meanwhile, please update the package to the new snapshot. I've prepared the package in user/lkundrak/NetworkManager-1.2 branch.

Alternatively, just assign this to me and I'll do the update.

Thank you!
Lubo
Comment 1 Ivan Romanov 2015-09-05 00:53:50 EDT
URL in spec is wrong. 

$ spectool -g -S NetworkManager-l2tp.spec 
Getting https://github.com/seriyps/NetworkManager-l2tp/archive/1.2.0/NetworkManager-l2tp-1.2.0.tar.xz to ./NetworkManager-l2tp-1.2.0.tar.xz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0curl: (22) The requested URL returned error: 404 Not Found
Comment 2 Lubomir Rintel 2015-09-07 03:51:17 EDT
No. The 1.2.0 version doesn't exist yet -- the package's a pre-release git snapshot. I've uploaded a snapshot to the lookaside (which is what sources points to).
Comment 3 Ivan Romanov 2015-09-07 04:35:38 EDT
Sorry I mean Source not URL tag.

As I understand you used snapshot from your own git repository. So you didn't use official sources. Spec says nothing about this. Also as I said before Source tag is not correct.

Look at https://bugzilla.redhat.com/show_bug.cgi?id=887674#c105 .
In this case we can use own sources. But .spec must explain this. And source tag must point to real source tarball.

Or we can wait when Sergey applied your pull request and set version tag. I sometimes see him in my Jabber so I can ask him. How many time we can wait?
Comment 4 Lubomir Rintel 2015-09-07 09:39:15 EDT
(In reply to Ivan Romanov from comment #3)
> Sorry I mean Source not URL tag.
> 
> As I understand you used snapshot from your own git repository. So you
> didn't use official sources. Spec says nothing about this. Also as I said
> before Source tag is not correct.
> 
> Look at https://bugzilla.redhat.com/show_bug.cgi?id=887674#c105 .
> In this case we can use own sources. But .spec must explain this. And source
> tag must point to real source tarball.

Yeah, sure. Feel free to use the changes I've done as the base for a proper packaging then. Alternatively, you can keep using the release tarball and just add patches on top of it. Whatever works for you.

> Or we can wait when Sergey applied your pull request and set version tag. I
> sometimes see him in my Jabber so I can ask him. How many time we can wait?

Well, that would be the most optimal solution.

I don't think there's a need to hurry -- the Fedora 23 is not yet released and this will only affect Fedora 24. The official release date for NetworkManager is not set yet, but it's likely sometime in November 2015. We'll announce it in advance and will probably do a couple of rounds of release candidates.

We're just playing it safe and started integrating it early so that there's plenty of time to test it. (And it would be really awesome if someone could test l2tp early, since we don't have the setup ourselves.)

The only problem is that now that we've imported the NetworkManager 1.2 snapshot into Fedora 24 the new nm-connection editor no longer works with the old l2tp preferences dialog.
Comment 5 Jan Kurik 2016-02-24 08:43:09 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Note You need to log in before you can comment on or make changes to this bug.