Bug 1260063 - After updating mock from 1.2.10 to 1.2.12 build fails with permission error
After updating mock from 1.2.10 to 1.2.12 build fails with permission error
Status: CLOSED DUPLICATE of bug 1239013
Product: Fedora EPEL
Classification: Fedora
Component: mock (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Clark Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 06:48 EDT by Dennis Jacobfeuerborn
Modified: 2015-09-04 07:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-04 07:07:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Jacobfeuerborn 2015-09-04 06:48:18 EDT
After updating mock to 1.2.12 due to:
https://bugzilla.redhat.com/show_bug.cgi?id=1259980
I can not build packages:

...
Start: cleaning yum metadata
Finish: cleaning yum metadata
ERROR: Exception(/var/lib/mock/conversis-7-x86_64/result/conversis-nagios-plugins-0.14-1.el7.src.rpm) Config(conversis-7-x86_64) 0 minutes 0 seconds
INFO: Results and/or logs in: /var/lib/mock/conversis-7-x86_64/result

ERROR: [Errno 1] Operation not permitted: '/var/lib/mock/conversis-7-x86_64/root/dev/pts/ptmx'

ERROR: The most common cause for this error is trying to run /usr/sbin/mock as an unprivileged user.
ERROR: Check your path to make sure that /usr/bin/ is listed before /usr/sbin, or manually run /usr/bin/mock to see if that fixes this problem.


The user I'm building with is member of the mock group and I'm explicitly invoking mock as /usr/bin/mock.
Comment 1 Miroslav Suchý 2015-09-04 07:07:17 EDT

*** This bug has been marked as a duplicate of bug 1239013 ***

Note You need to log in before you can comment on or make changes to this bug.