Bug 1260073 - SELinux is preventing su from 'link' accesses on the key Unknown.
SELinux is preventing su from 'link' accesses on the key Unknown.
Status: CLOSED DUPLICATE of bug 1138601
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:211c3b6d387599069041896c9ca...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 07:17 EDT by Tomáš Hozza
Modified: 2015-09-04 11:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-04 11:25:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomáš Hozza 2015-09-04 07:17:59 EDT
Description of problem:
I added user 'user' in Fedora docker container. Then run 'su - user' inside container. This caused the AVC on Host
SELinux is preventing su from 'link' accesses on the key Unknown.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that su should be allowed link access on the Unknown key by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep su /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:svirt_lxc_net_t:s0:c357,c608
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                Unknown [ key ]
Source                        su
Source Path                   su
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-128.12.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.0.4-301.fc22.x86_64 #1 SMP Thu
                              May 21 13:10:33 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-09-04 13:14:33 CEST
Last Seen                     2015-09-04 13:14:33 CEST
Local ID                      f511309d-68c6-4a89-a220-cf65201a0ffc

Raw Audit Messages
type=AVC msg=audit(1441365273.2:7812): avc:  denied  { link } for  pid=10899 comm="su" scontext=system_u:system_r:svirt_lxc_net_t:s0:c357,c608 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=key permissive=0


Hash: su,svirt_lxc_net_t,unconfined_t,key,link

Version-Release number of selected component:
selinux-policy-3.13.1-128.12.fc22.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.0.4-301.fc22.x86_64
type:           libreport
Comment 1 Daniel Walsh 2015-09-04 11:25:32 EDT

*** This bug has been marked as a duplicate of bug 1138601 ***

Note You need to log in before you can comment on or make changes to this bug.