Bug 126009 - error -50 while moving and dublicating files on shares - kernel 2.6 - and a patch
error -50 while moving and dublicating files on shares - kernel 2.6 - and a ...
Product: Fedora
Classification: Fedora
Component: netatalk (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Depends On:
  Show dependency treegraph
Reported: 2004-06-15 05:28 EDT by Götz Reinicke
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-06-16 18:28:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Götz Reinicke 2004-06-15 05:28:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de-AT;
rv:1.6) Gecko/20040113

Description of problem:

I recently installed a Fedora Core 2 Netatalk Server:

Kernel 2.6.6, netatalk 1.6.4, FS ext3

Now if I copy files from my G5 OS X 10.3.4 to the server or from the
server to the client things work fine.

If I try to dublicate or move the files on the server into a different
directory I get an error -50.

see also:

SOLUTION may be here:


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot the server and start netatalk

2. mount the shares and try to dublicate or copy files on the share.

3. error -50

Additional info:
Comment 1 Charlie Bennett 2004-09-22 17:28:34 EDT
I plan to address this in the near future (FC3 bug week).

Have your tried the recent netatalk 2.0 release candidates?  If
there's a final release by Bug Week I may swap in 2.0 rather than
applying this patch.
Comment 2 Götz Reinicke 2004-09-23 02:19:06 EDT
No, I haven't tried 2.0 yet, because there would be a lot of different
things to concider regarding the filehandling (AFAIK). e.g. the
.apple_double thing etc. have changed and I didn't had the time to
think about migrating about 200 GB of data. For the new OS X Client we
use samba anyway...and I have to migrate the same data from samba 2 to
samba 3 ;-).
Comment 3 Matthew Miller 2005-04-26 11:41:01 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 4 Jason Vas Dias 2005-06-16 18:28:42 EDT
This problem is definitely fixed with netatalk-2.0.2+ 
(latest version netatalk-2.0.3-1). 

Note You need to log in before you can comment on or make changes to this bug.