Bug 126019 - Installed patches and now ssl over http fails
Installed patches and now ssl over http fails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openssl (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-15 08:08 EDT by Jim Hanley
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-15 19:50:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Hanley 2004-06-15 08:08:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.1)
Gecko/20020920 Netscape/7.0

Description of problem:
after up2date installed a set of patches (and a week later rebooted),
I am unable to get to the apache server over https.

Errors in /var/log/httpd/error_log are:
/usr/sbin/httpd: relocation error: /lib/libpcre.so.0: symbol memset,
version GLIBC_2.0 not defined in file libc.so.6 with link time reference

Some packages of what I beleive may be important (but not mentioned in
up2date log):
glibc-2.3.2-101.4
glibc-common-2.3.2-101.4
glibc-devel-2.3.2-101.4
glibc-headers-2.3.2-101.4
glibc-kernheaders-2.4-8.36
glib-devel-1.2.10-11
httpd-2.0.49-1.1
openssh-3.6.1p2-19
openssh-askpass-3.6.1p2-19
openssh-askpass-gnome-3.6.1p2-19
openssh-clients-3.6.1p2-19
openssh-server-3.6.1p2-19
openssl-0.9.7a-33.10
openssl-devel-0.9.7a-33.10
pcre-4.4-1

entries from the /var/log/up2date from before the last reboot:
[Thu Jun  3 12:10:04 2004] up2date installing packages:
['cvs-1.11.15-5', 'gaim-0.77-2.FC1', 'gimp-1.2.
5-2', 'httpd-2.0.49-1.1', 'kdelibs-3.1.4-5', 'libpcap-0.7.2-8.fc1.2',
'mod_ssl-2.0.49-1.1', 'php-4.3.6-
1.3', 'php-mysql-4.3.6-1.3', 'tcpdump-3.7.2-8.fc1.2'] 
[Thu Jun  3 12:19:49 2004] up2date deleting
/var/spool/up2date/cvs-1.11.15-5.i386.hdr
[Thu Jun  3 12:19:49 2004] up2date deleting
/var/spool/up2date/cvs-1.11.15-5.i386.rpm
[Thu Jun  3 12:19:49 2004] up2date deleting
/var/spool/up2date/gaim-0.77-2.FC1.i386.hdr
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/gaim-0.77-2.FC1.i386.rpm
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/gimp-1.2.5-2.i386.hdr
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/gimp-1.2.5-2.i386.rpm
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/httpd-2.0.49-1.1.i386.hdr
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/httpd-2.0.49-1.1.i386.rpm
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/kdelibs-3.1.4-5.i386.hdr
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/kdelibs-3.1.4-5.i386.rpm
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/libpcap-0.7.2-8.fc1.2.i386.hdr
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/libpcap-0.7.2-8.fc1.2.i386.rpm
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/mod_ssl-2.0.49-1.1.i386.hdr
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/mod_ssl-2.0.49-1.1.i386.rpm
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/php-4.3.6-1.3.i386.hdr
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/php-4.3.6-1.3.i386.rpm
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/php-mysql-4.3.6-1.3.i386.hdr
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/php-mysql-4.3.6-1.3.i386.rpm
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/tcpdump-3.7.2-8.fc1.2.i386.hdr
[Thu Jun  3 12:19:50 2004] up2date deleting
/var/spool/up2date/tcpdump-3.7.2-8.fc1.2.i386.rpm
[Sat Jun  5 19:56:59 2004] up2date availablePackageList from network
[Sat Jun  5 19:58:02 2004] up2date installing packages:
['krb5-devel-1.3.3-6', 'krb5-libs-1.3.3-6', 'st
race-4.5.4-0.FC1'] 
[Sat Jun  5 19:58:34 2004] up2date deleting
/var/spool/up2date/krb5-devel-1.3.3-6.i386.hdr
[Sat Jun  5 19:58:34 2004] up2date deleting
/var/spool/up2date/krb5-devel-1.3.3-6.i386.rpm
[Sat Jun  5 19:58:34 2004] up2date deleting
/var/spool/up2date/krb5-libs-1.3.3-6.i386.hdr
[Sat Jun  5 19:58:34 2004] up2date deleting
/var/spool/up2date/krb5-libs-1.3.3-6.i386.rpm
[Sat Jun  5 19:58:34 2004] up2date deleting
/var/spool/up2date/strace-4.5.4-0.FC1.i386.hdr
[Sat Jun  5 19:58:34 2004] up2date deleting
/var/spool/up2date/strace-4.5.4-0.FC1.i386.rpm


Version-Release number of selected component (if applicable):
See description

How reproducible:
Always

Steps to Reproduce:
 1.Start httpd
 2.Go to httpd server from browser over ssl port


Actual Results:
 1.Page containes no data
 2.New error line inserted into /var/log/httpd/ssl_error_log

Expected Results:  Show content of page over enrypted link

Additional info:

We are unable to access the server securely and privately via https,
but we CAN use ssh to login into the a shell on the server.

The other strange thing is that the server worked fine until
rebooting.  Perhaps the old .so was cached in memory?
Comment 1 Jim Hanley 2004-06-15 19:50:46 EDT
Okay I must have updated the machine in the middle of the up2date
repository being updated because there were a couple more today and
now it works.

Note You need to log in before you can comment on or make changes to this bug.