Bug 1260231 - [RFE] Allow for RHEV to import an existing storage domain [NEEDINFO]
[RFE] Allow for RHEV to import an existing storage domain
Status: CLOSED DUPLICATE of bug 1132709
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.6.0
Assigned To: Maor
storage
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 16:45 EDT by Robert McSwain
Modified: 2015-09-06 05:09 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-06 05:09:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: needinfo? (rmcswain)


Attachments (Terms of Use)

  None (edit)
Description Robert McSwain 2015-09-04 16:45:09 EDT
What is the nature and description of the request?  
      I'd like to use the Import Storage Domain feature along with array level cloning to provide Disaster Recovery and even backup/restore functionality for my VMs.  Our single RHEV-M instance manages 2 data centers that are physically independent from each other.  We plan to use storage level cloning to clone the Main DC storage domain onto another array, then present that SD to the DR hosts and use Import Storage Domain to bring up the VMs in the DR site.  By taking nightly snapshots of the storage domain, we could attach storage domains from previous days in order to "recover" a VM 

Why does you need this from a business perspective? (List the business requirements here)  
      We are investigating strategies for protecting our workloads running in RHEV.  A feature like this could be used for VM level Disaster Recovery and/or  to replace OS level/client backups entirely.

How would you like to achieve this? (List the functional requirements here)  
      From a high level I see the Import Storage Domain feature in RHEV 3.5 is almost able to achieve what I'm looking for.  If the RHEV-M instance was able to detect (automatically, or via user input) that a storage domain that I'm importing is a clone of an existing datacenter, it could provide an option to change the id of that storage domain so it doesn't conflict with the original, then provide the ability to import it just like any other storage domain.
  - Import a block-level cloned storage domain into the same RHEV-M instance where the source storage domain is currently mounted, without first deactivating the source SD.
  - Visibility into the cloned storage domain so that VMs can be imported/run from it


For each functional requirement listed, specify how Red Hat and the you can test to confirm the requirement is successfully implemented.  
  - Clone an existing storage domain, then import it back into the same RHEV-M instance without first detaching the original
  - Once the cloned SD is imported, all the VMs that exist on the original SD should be visible and importable/runnable.
      
Do you have any specific timeline dependencies and which release would they like to target (i.e. RHEV 3.6, RHEV 4.0)?  
    No specific timeline.  RHEV 4.0 would be fine.

Would you be able to assist in testing this functionality if implemented?
    Definitely
Comment 2 Oved Ourfali 2015-09-06 02:26:29 EDT
Robert, I think it was covered by Bug 716511 (PRD35 - [RFE] support discovery of existing virtual machines on RHEV storage). Feature page in 
http://www.ovirt.org/Features/ImportStorageDomain

Can you take a look?
Comment 3 Allon Mureinik 2015-09-06 05:06:27 EDT
(In reply to Oved Ourfali from comment #2)
> Robert, I think it was covered by Bug 716511 (PRD35 - [RFE] support
> discovery of existing virtual machines on RHEV storage). Feature page in 
> http://www.ovirt.org/Features/ImportStorageDomain
There are missing bits here. As noted in comment #1

(In reply to Robert McSwain from comment #0)
>       From a high level I see the Import Storage Domain feature in RHEV 3.5
> is almost able to achieve what I'm looking for.  If the RHEV-M instance was
> able to detect (automatically, or via user input) that a storage domain that
> I'm importing is a clone of an existing datacenter, it could provide an
> option to change the id of that storage domain so it doesn't conflict with
> the original, then provide the ability to import it just like any other
> storage domain.
Comment 4 Allon Mureinik 2015-09-06 05:09:22 EDT
Robert, this seems like the same issue as reported in bug 1132709. Let's move the discussion there, so we have a single place to track all the requirements around this feature.

*** This bug has been marked as a duplicate of bug 1132709 ***

Note You need to log in before you can comment on or make changes to this bug.