Bug 126033 - zfcp only recognizes one of four disks in map
zfcp only recognizes one of four disks in map
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
: 119616 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-15 09:50 EDT by Brock Organ
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:24:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brock Organ 2004-06-15 09:50:05 EDT
* RHEL3 U2 AS
* kernel-2.4.21-15.EL.s390
* testing erratum RHBA-2004:226-13 - Updated mdadm package fixes md
device issues
* multipath using zfcp regression tests

when configuring zfcp to have four paths to the same SCSI device, the
zfcp map should detect and configure /dev/sda, /dev/sdb, /dev/sdc and
/dev/sdd ... however, when inserting the zfcp module, only /dev/sda is
configured (output from dmesg):

> zfcp: zfcp_module_init: driver version 0x3009d
> scsi0 : zfcp
> scsi1 : zfcp
> scsi2 : zfcp
> scsi3 : zfcp
>   Vendor: IBM       Model: 2105F20           Rev: .674
>   Type:   Direct-Access                      ANSI SCSI revision: 03
> Attached scsi disk sda at scsi0, channel 0, id 1, lun 0
> SCSI device sda: 7812544 512-byte hdwr sectors (4000 MB)
>  sda: sda1

the dmesg text should also include 3 other entries (for sdb sdc and
sdd) ... this is surprising also since the map does contain all 4 entries:

> # cat /proc/scsi/zfcp/map
> 0x4000 0x00000001:0x5005076300c213e9 0x00000000:0x5010000000000000
> 0x4001 0x00000002:0x5005076300cb13e9 0x00000001:0x5010000000000000
> 0x4002 0x00000003:0x5005076300c613e9 0x00000002:0x5010000000000000
> 0x4003 0x00000004:0x5005076300cf13e9 0x00000003:0x5010000000000000
> #
Comment 1 Brock Organ 2004-08-25 18:50:27 EDT
*** Bug 119616 has been marked as a duplicate of this bug. ***
Comment 2 Brock Organ 2004-12-16 17:39:10 EST
IBM is not seeing this in their testing ... this may indicate a
problem with the format of the scsi map in /etc/modules.conf ... will
test other formats ...
Comment 3 RHEL Product and Program Management 2007-10-19 15:24:12 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.