Bug 1260371 - GUI shows incorrect compatibility version during edit if the Data Center version is old
GUI shows incorrect compatibility version during edit if the Data Center vers...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.5.3
Unspecified Linux
unspecified Severity low
: ---
: 3.6.0
Assigned To: Eli Mesika
Pavel Stehlik
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-06 05:28 EDT by nijin ashok
Modified: 2016-02-10 14:42 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-16 04:52:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nijin ashok 2015-09-06 05:28:36 EDT
Description of problem:

If the Cluster Version was only upgraded and the Data Center version is still using old version then the "Edit Cluster" will shows the "Data center" version as a default form field for "Compatibility Version". One has to manually change the cluster compatibility everytime to make a change or to save the form.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization 3.5


How reproducible:
100%

Steps to Reproduce:
1. Create a data center and cluster of version 3.4
2. Upgrade the cluster version to 3.5 
3. Try to edit the cluster and can see that the default compatibility version is 3.4 . We need to manually change this to 3.5 for saving the form.

Actual results:
Cluster compatibility version is showing incorrect value in "Edit Cluster".

Expected results:
Cluster compatibility version should show the correct value.

Additional info:
Comment 1 Eli Mesika 2015-09-09 07:13:37 EDT
Hi

Do you mean that you have 3.4 hosts in a 3.4 cluster in a 3.4 DC and now you had upgraded all the hosts that belongs to the 3.4 cluster to 3.5 and you expect now that the edit dialog on that cluster will show 3.5 as the comparability version ???
Comment 2 nijin ashok 2015-09-10 08:54:15 EDT
(In reply to Eli Mesika from comment #1)
> Hi
> 
> Do you mean that you have 3.4 hosts in a 3.4 cluster in a 3.4 DC and now you
> had upgraded all the hosts that belongs to the 3.4 cluster to 3.5 and you
> expect now that the edit dialog on that cluster will show 3.5 as the
> comparability version ???

Yes, When we upgrade the 3.4 cluster version to 3.5 and if the Data Center version is still in 3.4, the edit cluster button is now showing as 3.4.
Comment 3 Eli Mesika 2015-09-10 10:37:59 EDT
(In reply to nijin ashok from comment #2)

Hi again

In that case it is functioning as designed.
The comparability version is on the engine side logic and is not reported from VDSM , also, the Cluster itself is a logical entity on the engine side while in VDSM side we are aware only to the Host as an entity.

Due to that, I recommend to close this as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.