Bug 1260373 - clinfo stops with error
clinfo stops with error
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: clinfo (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Deutsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-06 05:31 EDT by Kim Bisgaard
Modified: 2015-10-11 05:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-11 04:59:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kim Bisgaard 2015-09-06 05:31:06 EDT
Description of problem:
clinfo tries to load wrong driver - i think ;-)

Xorg uses radeon driver, while this tried to find/load adgcn

Version-Release number of selected component (if applicable):
clinfo-0.1-0.7.git20150215.94fdb47.fc23.x86_64
libclc-0.0.1-10.20140901gite822ae3.fc23.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. run clinfo

Actual results:
$ clinfo           
Number of platforms                               2
  Platform Name                                   Clover
  Platform Vendor                                 Mesa
  Platform Version                                OpenCL 1.1 MESA 11.0.0-rc1
  Platform Profile                                FULL_PROFILE
  Platform Extensions                             cl_khr_icd
  Platform Extensions function suffix             MESA

  Platform Name                                   Portable Computing Language
  Platform Vendor                                 The pocl project
  Platform Version                                OpenCL 1.2 pocl 0.11
  Platform Profile                                FULL_PROFILE
  Platform Extensions                             cl_khr_icd
  Platform Extensions function suffix             POCL

  Platform Name                                   Clover
Number of devices                                 1
  Device Name                                     AMD KAVERI (DRM 2.43.0, LLVM 3.6.1)
  Device Vendor                                   AMD
  Device Vendor ID                                0x1002
  Device Version                                  OpenCL 1.1 MESA 11.0.0-rc1
  Driver Version                                  11.0.0-rc1
  Device OpenCL C Version                         OpenCL C 1.1 
  Device Type                                     GPU
  Device Profile                                  FULL_PROFILE
  Max compute units                               5
  Max clock frequency                             720MHz
  Max work item dimensions                        3
  Max work item sizes                             256x256x256
  Max work group size                             256
=== CL_PROGRAM_BUILD_LOG ===
fatal error: cannot open file '/usr/lib64/clc//kaveri-amdgcn--.bc': No such file or directory
  Preferred work group size multiple              fatal error: cannot open file '/usr/lib64/clc//kaveri-amdgcn--.bc': No such file or directory

....

Expected results:


Additional info:
ls -l /usr/lib64/clc
total 11964
lrwxrwxrwx. 1 root root      16 Jun 17 18:54 aruba-r600--.bc -> cayman-r600--.bc
-rw-r--r--. 1 root root 1783940 Jun 17 18:54 barts-r600--.bc
lrwxrwxrwx. 1 root root      16 Jun 17 18:54 bonaire-r600--.bc -> tahiti-r600--.bc
lrwxrwxrwx. 1 root root      15 Jun 17 18:54 caicos-r600--.bc -> barts-r600--.bc
-rw-r--r--. 1 root root 1783940 Jun 17 18:54 cayman-r600--.bc
-rw-r--r--. 1 root root 1783940 Jun 17 18:54 cedar-r600--.bc
-rw-r--r--. 1 root root 1783940 Jun 17 18:54 cypress-r600--.bc
lrwxrwxrwx. 1 root root      16 Jun 17 18:54 hainan-r600--.bc -> tahiti-r600--.bc
lrwxrwxrwx. 1 root root      16 Jun 17 18:54 hawaii-r600--.bc -> tahiti-r600--.bc
lrwxrwxrwx. 1 root root      17 Jun 17 18:54 hemlock-r600--.bc -> cypress-r600--.bc
lrwxrwxrwx. 1 root root      15 Jun 17 18:54 juniper-r600--.bc -> cedar-r600--.bc
lrwxrwxrwx. 1 root root      16 Jun 17 18:54 kabini-r600--.bc -> tahiti-r600--.bc
lrwxrwxrwx. 1 root root      16 Jun 17 18:54 kaveri-r600--.bc -> tahiti-r600--.bc
lrwxrwxrwx. 1 root root      16 Jun 17 18:54 mullins-r600--.bc -> tahiti-r600--.bc
-rw-r--r--. 1 root root 1660660 Jun 17 18:54 nvptx64--nvidiacl.bc
-rw-r--r--. 1 root root 1656540 Jun 17 18:54 nvptx--nvidiacl.bc
lrwxrwxrwx. 1 root root      16 Jun 17 18:54 oland-r600--.bc -> tahiti-r600--.bc
lrwxrwxrwx. 1 root root      15 Jun 17 18:54 palm-r600--.bc -> cedar-r600--.bc
lrwxrwxrwx. 1 root root      16 Jun 17 18:54 pitcairn-r600--.bc -> tahiti-r600--.bc
lrwxrwxrwx. 1 root root      15 Jun 17 18:54 redwood-r600--.bc -> cedar-r600--.bc
lrwxrwxrwx. 1 root root      15 Jun 17 18:54 sumo2-r600--.bc -> cedar-r600--.bc
lrwxrwxrwx. 1 root root      15 Jun 17 18:54 sumo-r600--.bc -> cedar-r600--.bc
-rw-r--r--. 1 root root 1784584 Jun 17 18:54 tahiti-r600--.bc
lrwxrwxrwx. 1 root root      15 Jun 17 18:54 turks-r600--.bc -> barts-r600--.bc
lrwxrwxrwx. 1 root root      16 Jun 17 18:54 verde-r600--.bc -> tahiti-r600--.bc

excerpt from Xorg...log:
[    42.757] (==) AIGLX enabled
[    42.757] (II) LoadModule: "radeon"
[    42.801] (II) Loading /usr/lib64/xorg/modules/drivers/radeon_drv.so
[    42.828] (II) Module radeon: vendor="X.Org Foundation"
[    42.828]    compiled for 1.17.2, module version = 7.5.99
[    42.828]    Module class: X.Org Video Driver
[    42.828]    ABI class: X.Org Video Driver, version 19.0
[    42.828] (II) RADEON: Driver for ATI Radeon chipsets:
Comment 1 Fabian Deutsch 2015-09-06 05:51:59 EDT
Looks like we need to rebuild libclc with kaveri support.

I'lll try to look into this next week.
Comment 2 Kim Bisgaard 2015-10-11 04:59:40 EDT
Looks much better now :-) THANKS!

libclc-0.0.1-11.20150918git4346c30.fc23.x86_64
clinfo-0.1-0.7.git20150215.94fdb47.fc23.x86_64

> clinfo 
Number of platforms                               2
  Platform Name                                   Clover
  Platform Vendor                                 Mesa
  Platform Version                                OpenCL 1.1 MESA 11.0.0
  Platform Profile                                FULL_PROFILE
  Platform Extensions                             cl_khr_icd
  Platform Extensions function suffix             MESA

  Platform Name                                   Portable Computing Language
  Platform Vendor                                 The pocl project
  Platform Version                                OpenCL 1.2 pocl 0.12-pre
  Platform Profile                                FULL_PROFILE
  Platform Extensions                             cl_khr_icd
  Platform Extensions function suffix             POCL

  Platform Name                                   Clover
Number of devices                                 1
  Device Name                                     AMD KAVERI (DRM 2.43.0, LLVM 3.7.0)
  Device Vendor                                   AMD
  Device Vendor ID                                0x1002
  Device Version                                  OpenCL 1.1 MESA 11.0.0
  Driver Version                                  11.0.0
  Device OpenCL C Version                         OpenCL C 1.1 
  Device Type                                     GPU
  Device Profile                                  FULL_PROFILE
  Max compute units                               5
  Max clock frequency                             720MHz
  Max work item dimensions                        3
  Max work item sizes                             256x256x256
  Max work group size                             256
  Preferred work group size multiple              64
  Preferred / native vector sizes                 
    char                                                16 / 16      
    short                                                8 / 8       
    int                                                  4 / 4       
    long                                                 2 / 2       
    half                                                 0 / 0        (n/a)
    float                                                4 / 4       
    double                                               2 / 2        (cl_khr_fp64)
  Half-precision Floating-point support           (n/a)
  Single-precision Floating-point support         (core)
    Denormals                                     No
    Infinity and NANs                             Yes
    Round to nearest                              Yes
    Round to zero                                 No
    Round to infinity                             No
    IEEE754-2008 fused multiply-add               No
    Support is emulated in software               No
    Correctly-rounded divide and sqrt operations  No
  Double-precision Floating-point support         (cl_khr_fp64)
    Denormals                                     Yes
    Infinity and NANs                             Yes
    Round to nearest                              Yes
    Round to zero                                 Yes
    Round to infinity                             Yes
    IEEE754-2008 fused multiply-add               Yes
    Support is emulated in software               No
    Correctly-rounded divide and sqrt operations  No
  Address bits                                    32, Little-Endian
  Global memory size                              1073741824 (1024MiB)
  Error Correction support                        No
  Max memory allocation                           268435456 (256MiB)
  Unified memory for Host and Device              Yes
  Minimum alignment for any data type             128 bytes
  Alignment of base address                       1024 bits (128 bytes)
  Global Memory cache type                        None
  Image support                                   No
  Local memory type                               Local
  Local memory size                               32768 (32KiB)
  Max constant buffer size                        268435456 (256MiB)
  Max number of constant args                     16
  Max size of kernel argument                     1024
  Queue properties                                
    Out-of-order execution                        No
    Profiling                                     Yes
  Profiling timer resolution                      0ns
  Execution capabilities                          
    Run OpenCL kernels                            Yes
    Run native kernels                            No
  Device Available                                Yes
  Compiler Available                              Yes
  Device Extensions                               cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_byte_addressable_store cl_khr_fp64

  Platform Name                                   Portable Computing Language
Number of devices                                 1
  Device Name                                     pthread-AMD A10-7700K Radeon R7, 10 Compute Cores 4C+6G
  Device Vendor                                   AuthenticAMD
  Device Vendor ID                                0x1022
  Device Version                                  OpenCL 1.2 pocl
  Driver Version                                  0.12-pre
  Device OpenCL C Version                         OpenCL C 1.2
  Device Type                                     CPU, Default
  Device Profile                                  FULL_PROFILE
  Max compute units                               4
  Max clock frequency                             3400MHz
  Device Partition                                (core)
    Max number of sub-devices                     4
    Supported partition types                     equally, by counts
  Max work item dimensions                        3
  Max work item sizes                             4096x4096x4096
  Max work group size                             4096
  Preferred work group size multiple              8
  Preferred / native vector sizes                 
    char                                                16 / 16      
    short                                                8 / 8       
    int                                                  4 / 4       
    long                                                 2 / 2       
    half                                                 8 / 8        (n/a)
    float                                                4 / 4       
    double                                               2 / 2        (cl_khr_fp64)
  Half-precision Floating-point support           (n/a)
  Single-precision Floating-point support         (core)
    Denormals                                     No
    Infinity and NANs                             Yes
    Round to nearest                              Yes
    Round to zero                                 No
    Round to infinity                             No
    IEEE754-2008 fused multiply-add               No
    Support is emulated in software               No
    Correctly-rounded divide and sqrt operations  No
  Double-precision Floating-point support         (cl_khr_fp64)
    Denormals                                     No
    Infinity and NANs                             Yes
    Round to nearest                              Yes
    Round to zero                                 No
    Round to infinity                             No
    IEEE754-2008 fused multiply-add               No
    Support is emulated in software               No
    Correctly-rounded divide and sqrt operations  No
  Address bits                                    64, Little-Endian
  Global memory size                              7255506944 (6.757GiB)
  Error Correction support                        No
  Max memory allocation                           7255506944 (6.757GiB)
  Unified memory for Host and Device              Yes
  Minimum alignment for any data type             128 bytes
  Alignment of base address                       1024 bits (128 bytes)
  Global Memory cache type                        Read/Write
  Global Memory cache size                        16384
  Global Memory cache line                        64 bytes
  Image support                                   Yes
    Max number of samplers per kernel             16
    Max size for 1D images from buffer            453469184 pixels
    Max 1D or 2D image array size                 2048 images
    Max 2D image size                             16384x16384 pixels
    Max 3D image size                             2048x2048x2048 pixels
    Max number of read image args                 128
    Max number of write image args                128
  Local memory type                               Global
  Local memory size                               7255506944 (6.757GiB)
  Max constant buffer size                        7255506944 (6.757GiB)
  Max number of constant args                     8
  Max size of kernel argument                     1024
  Queue properties                                
    Out-of-order execution                        No
    Profiling                                     Yes
  Profiling timer resolution                      0ns
  Execution capabilities                          
    Run OpenCL kernels                            Yes
    Run native kernels                            Yes
  Prefer user sync for interop                    Yes
  printf() buffer size                            1048576 (1024KiB)
  Built-in kernels                                
  Device Available                                Yes
  Compiler Available                              Yes
  Linker Available                                Yes
  Device Extensions                               cl_khr_fp64 cl_khr_byte_addressable_store

NULL platform behavior
  clGetPlatformInfo(NULL, CL_PLATFORM_NAME, ...)  Clover
  clGetDeviceIDs(NULL, CL_DEVICE_TYPE_ALL, ...)   Success [MESA]
  clCreateContext(NULL, ...) [default]            Success [MESA]
  clCreateContext(NULL, ...) [other]              Success [POCL]
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_CPU)  No devices found in platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_GPU)  Success (1)
    Platform Name                                 Clover
    Device Name                                   AMD KAVERI (DRM 2.43.0, LLVM 3.7.0)
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_ACCELERATOR)  No devices found in platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_CUSTOM)  No devices found in platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_ALL)  Success (1)
    Platform Name                                 Clover
    Device Name                                   AMD KAVERI (DRM 2.43.0, LLVM 3.7.0)

ICD loader properties
  ICD loader Name                                 OpenCL ICD Loader
  ICD loader Vendor                               OCL Icd free software
  ICD loader Version                              2.2.7
  ICD loader Profile                              OpenCL 1.2

Note You need to log in before you can comment on or make changes to this bug.