Bug 126038 - Conditionalize SELinux support in procps
Conditionalize SELinux support in procps
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: procps (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-15 10:58 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-27 13:46:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-06-15 10:58:12 EDT
Description of problem:
Well, I would prefer a conditionalisation of SELinux the support in 
procps' spec file.

Version-Release number of selected component (if applicable):
procps-3.2.1-5

Actual results / Expected results:
--- snipp ---
--- procps.spec       2004-06-14 22:54:00.000000000 +0200
+++ procps.spec.rsc   2004-06-15 16:56:16.000000000 +0200
@@ -1,3 +1,7 @@
+%if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1}
+%define WITH_SELINUX 1
+%endif
+
 Summary: System and process monitoring utilities.
 Name: procps
 Version: 3.2.1
@@ -39,10 +43,12 @@
 %setup -q

 %patch1 -p1 -b .nostrip
+%if %{WITH_SELINUX}
 %patch3 -p1 -b .selinux
+%patch6 -p1 -b .selinux-workaround
+%endif
 %patch4 -p1 -b .misc
 %patch5 -p1 -b .FAQ
-%patch6 -p1 -b .selinux-workaround
 cp %SOURCE1 .

 %build
@@ -75,6 +81,9 @@
 %attr(0644,root,root) %{_mandir}/man5/*

 %changelog
+* Tue Jun 15 2004 Robert Scheck <redhat@linuxnetz.de>
+- Make the SELinux support conditional in the spec file
+
 * Mon Jun 14 2004 Dan Walsh <dwalsh@redhat.com> 3.2.1-5
 - Fix FAQ Line

--- snapp ---

Additional info:
I still know, that non SELinux is going away at Red Hat, but at 
current most of the packages have conditional SELinux support...why 
procps not? ;-)
Comment 1 Daniel Walsh 2004-06-15 13:02:10 EDT
SELinux has already been accepted upstream.  So conditionalizing it
makes no sense.  The problem is that the command qualifies that they
use upstream are the old ones.  So we are patching to match the new
standard of using -Z as the qualified.  Conditionalizing procps would
end up with 
SELinux supporting the old qualifiers.

Dan
Comment 2 Robert Scheck 2004-06-27 13:46:30 EDT
Hm okay...closing.

Note You need to log in before you can comment on or make changes to this bug.