Bug 1260410 - Error: "Unable to connect to Neutron" displays when instance table displays on project tab
Error: "Unable to connect to Neutron" displays when instance table displays o...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
5.0 (RHEL 7)
Unspecified Linux
high Severity high
: async
: 5.0 (RHEL 7)
Assigned To: Matthias Runge
Ido Ovadia
: Reopened, Triaged, ZStream
: 1274252 (view as bug list)
Depends On:
Blocks: 1300396
  Show dependency treegraph
 
Reported: 2015-09-06 10:51 EDT by Ido Ovadia
Modified: 2018-02-08 05:54 EST (History)
12 users (show)

See Also:
Fixed In Version: python-django-horizon-2014.1.5-2.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1300396 (view as bug list)
Environment:
Last Closed: 2016-03-24 10:03:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
horizon log (193.08 KB, text/plain)
2015-09-06 10:51 EDT, Ido Ovadia
no flags Details
neutron metadata agent.log (267.84 KB, text/plain)
2015-09-06 10:52 EDT, Ido Ovadia
no flags Details
neutron server log (5.75 MB, text/plain)
2015-09-06 10:54 EDT, Ido Ovadia
no flags Details
l3-aget.log (12.93 MB, text/plain)
2015-09-06 10:58 EDT, Ido Ovadia
no flags Details
openvswich-agent.log (9.05 MB, text/plain)
2015-09-06 11:02 EDT, Ido Ovadia
no flags Details

  None (edit)
Description Ido Ovadia 2015-09-06 10:51:21 EDT
Created attachment 1070749 [details]
horizon log

Description of problem:
=======================
Error: "Unable to connect to Neutron" displays when instance table displays on project tab. This error display after creating instance. 

Version-Release number of selected component:
=============================================
python-django-horizon-2014.1.5-1.el7ost.noarch
openstack-dashboard-2014.1.5-1.el7ost.noarchpython-neutron-2014.1.5-2.el7ost.noarch
openstack-neutron-openvswitch-2014.1.5-2.el7ost.noarch
openstack-neutron-2014.1.5-2.el7ost.noarch
python-neutronclient-2.3.4-3.el7ost.noarch
openstack-neutron-ml2-2014.1.5-2.el7ost.noarch

How reproducible:
=================
100%

Steps to Reproduce:
===================
1. Create a network
2. Launch an instance with that network

Actual results:
=================
Instances created successfully, but
Error: "Unable to connect to Neutron" displays on Project --> Instances

Expected results:
=================
Instances created successfully, no errors

Additional info:
Comment 3 Ido Ovadia 2015-09-06 10:52:58 EDT
Created attachment 1070750 [details]
neutron metadata agent.log
Comment 4 Ido Ovadia 2015-09-06 10:54:56 EDT
Created attachment 1070751 [details]
neutron server log
Comment 5 Ido Ovadia 2015-09-06 10:58:24 EDT
Created attachment 1070752 [details]
l3-aget.log
Comment 6 Ido Ovadia 2015-09-06 11:02:41 EDT
Created attachment 1070753 [details]
openvswich-agent.log
Comment 7 Matthias Runge 2015-09-07 03:13:43 EDT
This works with nova network, but not with neutron enabled.
Comment 9 RHEL Product and Program Management 2015-09-07 05:45:51 EDT
Quality Engineering Management has reviewed and declined this request.
You may appeal this decision by reopening this request.
Comment 11 Jon Schlueter 2015-09-09 08:50:21 EDT
Patch referenced in comment #8
https://review.openstack.org/#/c/189459/ - icehouse patch was abandoned
https://review.openstack.org/#/c/114088/ - master patch was merged
Comment 14 Matthias Runge 2015-10-23 16:20:04 EDT
*** Bug 1274252 has been marked as a duplicate of this bug. ***
Comment 17 Faiaz Ahmed 2015-11-23 23:44:02 EST
Hi,
Customer is requesting for the hotfix. I am not aware of the procedure for requesting the hotfix, do I need to follow a procedure / form to do that?

Cheers
Faiaz
Comment 25 Jon Schlueter 2016-01-20 11:27:55 EST
cloned and split bug for OSP 5 - rhel 6
Comment 30 Ido Ovadia 2016-03-23 05:59:58 EDT
Verified
========

python-django-horizon-2014.1.5-2.el7ost.noarch
Comment 32 errata-xmlrpc 2016-03-24 10:03:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0508.html

Note You need to log in before you can comment on or make changes to this bug.