Bug 1260433 - Boost RPM needs missing requirement (boost-date-time)
Boost RPM needs missing requirement (boost-date-time)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Jonathan Wakely
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-06 16:36 EDT by Onyeibo Oku
Modified: 2015-12-07 07:05 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 07:05:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Onyeibo Oku 2015-09-06 16:36:53 EDT
Description of problem:
Boost has unsatisfied basic requirements (i.e. boost-date-time(x86-64) = 1.59.0-3.fc24)

Version-Release number of selected component (if applicable):
1.59.0-3.fc24

How reproducible:
Consistent on this machine

Steps to Reproduce:
1. Install Fedora rawhide from a live media predating version 1.59.0-3.fc24
2. Update all rpms from rawhide repo
3. dnf install boost

Actual results:
Error: package boost-1.59.0-3.fc24.x86_64 requires boost-date-time(x86-64) = 1.59.0-3.fc24, but none of the providers can be installed

Expected results:
clean installation of boost

Additional info:
Comment 1 Jonathan Wakely 2015-09-06 17:15:40 EDT
Please install the 'yum' package and run 'yum-deprecated install boost-date-time' to see the reason it can't be installed. It's probably because you already have some package installed that is still linked against boost 1.58.0 and hasn't been rebuilt. Several packages such as libreoffice, libkolab and kdepim-runtime still need to be rebuilt by their maintainers.
Comment 2 Onyeibo Oku 2015-09-06 18:17:41 EDT
I was able to install boost-date-time-1.59.0-3.fc24 using gnome-software.  Dnf then installed boost boost-devel without errors.  So, why didn't dnf do the installation in the first place?
Comment 3 Jonathan Wakely 2015-09-06 18:39:41 EDT
I don't know, and dnf doesn't give enough info to find out, that's why I asked you to try using yum.
Comment 4 Jonathan Wakely 2015-12-07 07:05:07 EST
The boost packages in rawhide have been updated several times since 1.59.0-3 and I don't see any problems with the boost-date-time package. If this problem persists with more a recent rawhide compose please re-open this bug report and try to use yum-deprecated, which is more informative than dnf.

Note You need to log in before you can comment on or make changes to this bug.