Bug 1260437 - SELinux is preventing wpa_supplicant from 'create' accesses on the netlink_generic_socket Unknown.
SELinux is preventing wpa_supplicant from 'create' accesses on the netlink_ge...
Status: CLOSED DUPLICATE of bug 1259180
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:27513d2ef4b064f374cb47a7aa9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-06 17:06 EDT by Nicolas Mailhot
Modified: 2015-09-11 08:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-11 08:19:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2015-09-06 17:06:23 EDT
Description of problem:
SELinux is preventing wpa_supplicant from 'create' accesses on the netlink_generic_socket Unknown.

*****  Plugin catchall (100. confidence) suggests   **************************

If vous pensez que wpa_supplicant devrait être autorisé à accéder create sur Unknown netlink_generic_socket par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep wpa_supplicant /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:NetworkManager_t:s0
Target Context                system_u:system_r:NetworkManager_t:s0
Target Objects                Unknown [ netlink_generic_socket ]
Source                        wpa_supplicant
Source Path                   wpa_supplicant
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-146.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.0-1.fc24.x86_64 #1 SMP Mon Aug
                              31 15:58:25 UTC 2015 x86_64 x86_64
Alert Count                   23
First Seen                    2015-09-06 11:20:18 CEST
Last Seen                     2015-09-06 23:05:21 CEST
Local ID                      20cdddba-795b-4b0b-a09c-a29d76ea0348

Raw Audit Messages
type=AVC msg=audit(1441573521.744:628): avc:  denied  { create } for  pid=1018 comm="wpa_supplicant" scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:system_r:NetworkManager_t:s0 tclass=netlink_generic_socket permissive=0


Hash: wpa_supplicant,NetworkManager_t,NetworkManager_t,netlink_generic_socket,create

Version-Release number of selected component:
selinux-policy-3.13.1-146.fc24.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.2.0-1.fc24.x86_64
type:           libreport

Potential duplicate: bug 1259932
Comment 1 Miroslav Grepl 2015-09-11 08:19:26 EDT

*** This bug has been marked as a duplicate of bug 1259180 ***

Note You need to log in before you can comment on or make changes to this bug.