Bug 1260540 - anaconda installation over previously defined mdadm raid1 yields a wrong root device in grub.conf
anaconda installation over previously defined mdadm raid1 yields a wrong root...
Status: CLOSED DUPLICATE of bug 841452
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.7
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-07 04:18 EDT by Tru Huynh
Modified: 2015-10-23 11:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-23 09:59:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 9410 None None None Never

  None (edit)
Description Tru Huynh 2015-09-07 04:18:07 EDT
Description of problem:
root device not correct while reinstalling on a previously defined /dev/md0 raid1

Version-Release number of selected component (if applicable):
anaconda-13.21.239-1.el6.centos.x86_64

How reproducible:
always

Steps to Reproduce:
1. 
2.
3.

Actual results:
(hd1,0) is used instead of (hd0,0) which is bad when one of the raid1 member is awol

Expected results:
(hd0,0) used

Additional info:
Comment 2 Samantha N. Bueno 2015-10-23 09:59:01 EDT
There are no logs, and the bug you've listed in the "See Also" field indicates this is probably grub's fault. So, duping to that one.

*** This bug has been marked as a duplicate of bug 841452 ***
Comment 3 Tru Huynh 2015-10-23 10:43:41 EDT
should it be re-open for grub, or the won't fix stand?

btw, all the details are in the centos bugs entry, feel free to re-assign to grub if you care.
Comment 4 Samantha N. Bueno 2015-10-23 11:54:07 EDT
I'm not sure -- you can try to get them to take another look at it, but since this bug is now marked as a duplicate, it would be better to comment/re-open that grub bug.

Note You need to log in before you can comment on or make changes to this bug.