Bug 1260636 - Support multi-monitor for RHEL 7 Spice guests properly
Support multi-monitor for RHEL 7 Spice guests properly
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Milan Zamazal
Pavel Stehlik
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-07 08:07 EDT by David Jaša
Modified: 2016-03-21 07:03 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-21 07:03:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.0.0?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2015-09-07 08:07:51 EDT
Description of problem:
At time of bug 787578 writing, RHEL 7 guests weren't around. RHEL 7 uses KMS driver that makes different use of qxl device memory regions to Windows or linux UMS drivers so the device should be set differently. These values assume maximum supported resolution per monitor 2560x1440 or 2048x2048 (fitting to 16 MB framebuffer):
# of monitors    ram    vram
1                64     32
2                64     64
4                128    128
The reasoning is that framebuffers are stored in bar#1 (vram) but during mode-switching, the bar needs to store both new and old mode at the same time, so the bar has to be bigger than simple sum of framebuffer sizes (4 * 16 = 64 MB)

OSs affected are all that were released in 2013 or later so the default for generic linux OSs should be KMS values. Note however that UMS can still be used when kms is disabled in the guest (by 'nomodeset' kernel CLI argument or by blacklisting of qxl.ko module) so it would be nice to give a chance to choose the model per VM.
Given all of above, osinfo seems to me as a good way to configure which driver memory settings for multimonitor should be used.


Version-Release number of selected component (if applicable):
3.3 - 3.6
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:49:34 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Michal Skrivanek 2016-03-21 06:11:48 EDT
do we still need to do anything? you did something for 3.6...
Comment 3 Milan Zamazal 2016-03-21 06:58:56 EDT
In 3.6, we use ram and vram values that are equal or higher than those given here, so the problem should be solved. And we needn't handle the RHEL-7 UMS case as KMS uses equal or higher values so UMS should work with those settings as well.

Note You need to log in before you can comment on or make changes to this bug.